I have been getting this error for months:

Error: Opening the cache(E: can not open /var/lib/apt/lists/
E: The package lists or status file could not be parsed or opened
This usually means your installed package have unmet dependencies

Then I try to fix it with:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoclean
sudo apt-get update --fix-missing

I tried these to no effect. Sometimes the error goes away for a while but then it comes back in a few minutes.

I also tried this

contents of /var/crash

Are the crash/whoopsie files related to the error?

  • No pictures of text please include the test in the body of the message,
    – David
    Sep 30, 2021 at 7:18
  • sorry I'm a new user. Is it clearer now?
    – Hetvi
    Sep 30, 2021 at 7:24
  • Does the directory /var/lib/apt/lists/ exist and have correct rights ? What is the output of ls -ld /var?/lib/apt/lists/ ?
    – Soren A
    Sep 30, 2021 at 7:32
  • ls: cannot access 'var?/lib/apt/lists/' No such file or directory
    – Hetvi
    Sep 30, 2021 at 7:38

1 Answer 1


This will occasionally happen when your apt lists are incomplete or broken. You can rebuild them like this:

  1. Open Terminal (if it's not already open)
  2. Remove the contents of the lists directory:
    sudo rm /var/lib/apt/lists/* -vf
  3. Rebuild the lists:
    sudo apt clean
    sudo apt update
  4. Update your system:
    sudo apt dist-upgrade

Hope this allows you to have an up-to-date system again 👍🏻

  • The same error is displayed again. It only disaapeared for a while.
    – Hetvi
    Sep 30, 2021 at 9:02
  • 1
    If the files in this directory are regularly being corrupted, then apt is being cancelled mid-process or your storage device is failing.
    – matigo
    Sep 30, 2021 at 9:21
  • How can I check the problem can you please tell me
    – Hetvi
    Sep 30, 2021 at 15:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .