0

If I go to a URL, say http://www.thenoblelion.com/, it brings me to the "Apache2 Ubuntu Default Page" instead of the actual URL. This is NOT my url, I'm trying to browse to it. It happens on a handful of other websites as well. And the URL's work on my Windows machine, but not my Ubuntu machine. I stopped Apache2 with "sudo systemctl disable apache2 && sudo systemctl stop apache2" but then I would get connection refused from the URL. Again, I'm not hosting ANY websites on this machine beyond a Plex Server. It's basically just my home PC. I'm running 20.04.3. How can I make this stop?

More info as requested:

I'm not purposely running apache. I was doing some Ansible training on my machine and maybe I installed it unintentionally. If I shut Apache down, I can't hit the URL I mentioned at all, which is weird.

Here are the results from systemdd-resolve --status

Global
       LLMNR setting: no                  
MulticastDNS setting: no                  
  DNSOverTLS setting: no                  
      DNSSEC setting: no                  
    DNSSEC supported: no                  
          DNSSEC NTA: 10.in-addr.arpa     
                      16.172.in-addr.arpa 
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa 
                      18.172.in-addr.arpa 
                      19.172.in-addr.arpa 
                      20.172.in-addr.arpa 
                      21.172.in-addr.arpa 
                      22.172.in-addr.arpa 
                      23.172.in-addr.arpa 
                      24.172.in-addr.arpa 
                      25.172.in-addr.arpa 
                      26.172.in-addr.arpa 
                      27.172.in-addr.arpa 
                      28.172.in-addr.arpa 
                      29.172.in-addr.arpa 
                      30.172.in-addr.arpa 
                      31.172.in-addr.arpa 
                      corp                
                      d.f.ip6.arpa        
                      home                
                      internal            
                      intranet            
                      lan                 
                      local               
                      private             
                      test                

Here's output from my /etc/hosts file:

27.0.0.1       localhost
127.0.1.1       casey-h9-1135

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
~                                                                               
~                      

     

I'm not running a virtual host on my machine.

Here's output from apache2ctl -S

/etc/apache2/sites-available$ apache2ctl -S
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
VirtualHost configuration:
*:80                   127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex watchdog-callback: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default 
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33 not_used
Group: name="www-data" id=33 not_used

Maybe I just need to completely uninstall Apache? I'm not using it.

And after some googling, I found this link: Permanently removing apache2 and removed apache2 and now it's stopped. Guess I need to pay better attention to what I'm installing and running. Thanks for the assistance.

3
  • Very odd behaviour. Can you edit your question to include: (1) the terminal output of systemd-resolve --status (2) the contents of /etc/hosts 🤔
    – matigo
    Sep 28, 2021 at 22:02
  • I think the problem is virtualhost, can you show the virtualhost config? Sep 29, 2021 at 3:46
  • If you are not running a web server, why are you running Apache? The symptoms indicate that you do run a web server, and that the requests somehow get routed to locahost
    – tripleee
    Sep 29, 2021 at 3:50

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.