I was following this tutorial to setup static ip address on my xfce 20.04 laptop. Everything was fine until I executed sudo netplan apply, after which the disconnect button on the network config panel was grayed out and I was no longer able to disconnect from neither my wifi nor ethernet. I tried few things like sudo systemctl restart network-manager.service, sudo rfkill unblock wifi, and sudo ifconfig wlp2s0 up (yes I checked the interface name), but none worked.
After a reboot, the problem went away, but then it came back after I executed sudo netplan apply.
My /etc/netplan/01-network-manager-all.yml looks like this:

# Let NetworkManager manage all devices on this system
  version: 2
  renderer: NetworkManager
      dhcp4: no
          addresses: [,]

For those wondering what I'm doing, I am setting up my home network with openwrt routers and it requires me to set a static ip address to be able to access them in their fail-safe mode. For that reason I am going to be changing my computer's config many times, so re-booting every time I change anything is something that I want to avoid.

  • You should've followed the "Configuring Static IP address on Ubuntu Desktop" instructions, not the ones for Ubuntu Server. Sep 27, 2021 at 11:19
  • What a bless! After I switched to the GUI as ChanganAuto suggested, It started working like a charm! I went to the edit connections menu and created two network connections, one is static and the other is DHCP assigned. Now I can select either of them, and it switches up instantly without issues. My issue is solved, but I think I'll keep this question up in case anyone finds why the network manager menu gets grayed out in the first place.
    – martian17
    Sep 27, 2021 at 13:11


You must log in to answer this question.

Browse other questions tagged .