0

my usb detected by pc but pc doesn't show it.
other usb work well but this one no. this usb works but I do not know what I did wrong that the pc did not show it anymore.(I was trying to bootable it to install Windows)
the result of lsblk for usb is (7.2G):
enter image description here
I think this link also had a problem with me, but I can't edit mount option.
i tried to format usb but it doesn't allow:
enter image description here

0
0

Once you format a USB stick as a bootable drive, you cannot use it for data storage.

USB sticks come with a FAT partition on them. Put simply, to write a bootable inmage on it, you have to erase that partition.

4
  • I tried to format it but it did not allow.
    – Truth
    Sep 27 at 8:32
  • The easy way to restore to a regular mass storage device is using the similarly named feature of MKUSB. Sep 27 at 8:41
  • @ChanganAuto Does that just reformat / write another FAT filesystem overtop of the bootable drive. I'll check out the man page and update the answer. Thanks
    – Nate T
    Sep 27 at 12:30
  • @NateT I'm not sure what it does under the hood. I suppose it writes a new partition table then creates and formats a new FAT32 partition. Sep 27 at 12:38
0

I hope you aren't running any virtualization software (Like VirtualBox, QEMU, KVM etc.,)

Does this command work (this is just to test if /dev/sdb is writable) ?

sudo umount /dev/sdb* ; sudo dd if=/dev/urandom of=/dev/sdb bs=1M count=10 status=progress && sync

(This command overwrites /dev/sdb ; beware not to overwrite important storage media)

If it works, open GParted, then select the device, create a new "msdos" partition table, then reboot and format with GNOME disks.

If it doesn't work, please post the error messages.

1
  • it says "umount: /dev/sdb: not mounted." usb doesn't have any partition and can't be mounted.I made a partition once and mounted it, and it was empty, but I could not copy anything on it.I deleted the partition and tried to install it again, which gave this error:"input/output error during write on /dev/sdb gparted"
    – Truth
    Sep 27 at 20:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.