4

Starting two days ago (9/22/21) on both of my Kubuntu machines Chrome no longer displays system title bars and borders. The option in settings is enabled. Disable/re-enable/reboot hasn't fixed it. All other applications display this correctly.

chrome

My machines are both Kubuntu. lsb_release -a says Ubuntu 20.04.3 LTS. Chrome is 94.0.4606.61.

I've received no responses on the KDE-users list. On the Gentoo list the one person who responded said he also didn't have the system title bar but when he reenabled the feature and for him it works.

Using the system title bar allows Chrome to be pinned to all virtual desktops which I need for media. In the immediate term I'm using Firefox for that purpose but would prefer to use Chrome.

Thanks in advance.

Chrome with Appearance & Fix setting

6
6

Per Google this is a new issue from 94

From Reddit, here is a (temporary) quick fix:

  • Ensure that "Use system title bar and borders" is set
  • Go to chrome://flags
  • Find the "use-ozone-platform" setting and change it from "default" to "disabled"
  • Relaunch Chrome
2
  • The same problem persists in the newly released 94.0.4606.71 version of Chrome. The workaround given in this answer works though. Oct 1 at 6:54
  • This problem was solved in version 95. Oct 20 at 8:53
2

Solution

Right click on the Chrome title bar, and check Use system title bars and borders (I tested this on Chromium in XFCE, but it should work on Chrome in KDE too).

solution Before enabling title bar

Now the title bar is there, and you can make it visible in every workspace.

after After enabling title bar


Background

Chrome is a GTK app. Like most other GTK apps it switched to CSD (client side decoration) in the recently released version 94. Now it draws its own title bar, instead of using the title bar provided by KDE Plasma.

10
  • I am using GNOME and the same problem mentioned in the Question is present here too, after the recent upgrade of Chrome. You cannot right click on the title bar and select "Always on Visible Workspace". Your answer does not make any difference in this respect. Sep 25 at 10:33
  • We need something like the one shown on this screenshot imgur.com/a/0l9FAuE (taken using Firefox). Sep 25 at 14:16
  • Prior to asking the questions I was already set to use GTK+ and the original post said the use system title bars didn't work. So far help for me either. PLEASE NOTE: A 'theme' is NOT a title bar. The CLient Side Decoration comment seems appropriate as to the possible cause of the problem though
    – LGTrader
    Sep 25 at 14:27
  • It didn't work for me on Kubuntu but one Gentoo use said he found turning on the ozone experimental option under chrome://flags worked for him. Anyone reading might try that out.
    – LGTrader
    Sep 25 at 14:28
  • By updated answer to you mean what looks like the secondary pulldown with the Always on Visible Workspace option? I always had the Use system title bar turned on. In your second screen shot you have the system title bar but I do not see that here on Chrome.
    – LGTrader
    Sep 25 at 14:54
1

Google Chrome beta works OK so hopfully when it migrates to stable this fault will be gone.

1
  • Thanks. Good to know.
    – LGTrader
    Sep 27 at 14:08
0

My answer is specifically for KDE but I suspect other desktop environments has similar capabilities.

SystemSettings->Shortcuts->KWin->Keep Window on All Desktop

and program it to something. I chose Meta+a (Windows key and a for 'all')

It appears to work for all app and it's a toggle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.