In previous versions of Ubuntu I was able to install the proprietary nvidia driver for the GeForce 210 graphics card under Additional Drivers in Software & Update but now there are "No additional drivers available".

I tried typing apt install nvidia-driver- and hit tab. If I'm not mistaken, I need nvidia-driver-340 but there is nothing below nvidia-driver-390.

Lastly, I downloaded the official driver from nvidia's web page and tried installing it directly but the installation was unsuccessful. The log says: fatal error: asm/kmap_types.h: No such file or directory

I reinstalled my Ubuntu 20.04 system because it stopped booting some weeks ago. The boot process started normally (black screen with Ubuntu written in white and a spinning "circle" above it) but then the screen went completely blank and there was occasionally a blinking underscore at the top left corner of the screen. At this point, no matter which key I hit, nothing happened. I don't know if the failure of my old system has anything to do with my current problem.

Now, I do not really care about which driver I'm using as long as it supports my screen's native resolution which is 2560x1080. nouveau only gives me 1920x1080.

  • 2
    Your card is now legacy and only nouveau is available. If the older driver version is no longer available in the repositories then trying to install from Nvidia's binaries (never recommended and strongly discouraged) will obviously NOT work either. Sep 23, 2021 at 18:18
  • @N0rbert I did the research. Recommending a PPA has its own set of risks and in this particular case the question is not if, it's when it'll break. But +1 for the effort. Sep 23, 2021 at 18:40
  • So I've just reinstalled 20.04 and went to Additional Drivers. Now, the nvidia driver did show up but its installation failed. Then I restarted the computer and it failed to boot. Same thing as with the old system, so it seems like it broke because of this issue. How could I have known that something bad was about to happen and how could I have prevented it? Sep 23, 2021 at 19:11
  • 1
    This is the same issue as Unable to use proprietary NVIDIA graphics driver after upgrading from Lubuntu 20.10 to 21.04: the Linux kernel in 21.04 removed support for some legacy Nvidia graphics cards, and the answer here is the same as over there.
    – gparyani
    Sep 24, 2021 at 7:51

1 Answer 1


There is a special PPA with legacy Nvidia 340 drivers.

You have to install drivers from it by using commands below:

sudo add-apt-repository ppa:kelebek333/nvidia-legacy
sudo apt-get update
sudo apt install nvidia-340 xorg-modulepath-fix 

and then reboot.

  • I did this on a 2 year old Dell Inspiron 7590, and was no longer able to boot. Fortunately, was able to get it uninstalled from recovery mode and get back into a functioning state.
    – Luke Bayes
    Dec 17, 2021 at 4:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.