0

I have an nvidia 1050ti. Recently installed kubuntu 20.04.3 and allowed 3rd party software during installation. After installation when I try to boot it just stays loading at the splash screen after grub, so broken system right after installation.

From recovery I tried ubuntu-driver autoinstall. This allowed me to at least get to the display manager but the scale is off, everything looks small, and I get micro-freezes, like every second I lose some frames or something. I uninstalled the nvidia drivers and that fixed the problem. However nouveau leaves a lot to be desired and I would like to have proper drivers installed.

I also tried to install without allowing 3rd party software, and the result is the same. It all works all right without the nvidia drivers but the moment I install them, either with ubuntu-driver or directly with apt, everything breaks.

I tried nvidia-driver-390 , 460 and 470. None works. Just as a note I also had a similar problem with debian and recently with arch, which never managed to fix either.

3
  • As always update UEFI. Then use the recommended driver version only, that is 470 (390 is a long term driver branch for legacy products, your isn't there yet). Make sure the correct (native) resolution is selected and increase scaling if you think it "looks small". What you refer to as "micro-freeses" ain't so because "lose(?) some frames" suggests a screen tearing issue for which you should enable force full composition (or something like that) in Nvidia X Server Settings. Sep 22 at 22:17
  • nouveau is an unofficial open-source replacement driver (i.e., "not from Nvidia") that is limited indeed for any current Nvidia hardware (it works sufficiently for most legacy hardware). And here's a comment (or two) that's a better answer than the one you got so far. Sep 22 at 22:18
  • With "update UEFI" you mean update the mother's firmware? I tried changing the scale thorough plasma's settings but it had no effect. Tried forcing composition through nvidia, both simple and full, but nothing. Also tried disabling flipping and vsync. Nothing
    – Reimon42
    Sep 24 at 14:31
0

since you said trying nvidia-driver-390 I can suggest you try some solutions. The first one is trying to get the drivers from Software & Updates, under the "aditional drivers" tab.enter image description here

In my case I already installed Ubuntu with the proprietary drivers, but you could try selecting the first option: proprietary, tested.

If it doesn't work you could try to purge any existing Nvidia drivers and reinstall them, you can do this by typing this on your terminal:

sudo apt-get remove --purge '^nvidia-.*'

Please be aware there's a dependency between one of the packages that will be removed and ubuntu-desktop, therefore you may as well need:

sudo apt-get install ubuntu-desktop

Then try to reinstall them via terminal, and search for the adequate drivers using:

apt search nvidia-driver

If nothing works, since you already tried Arch, you could perhaps try installing Ubuntu, it supported my card out of the box, or Fedora, which is RPM based, it has good out of the box support for Nvidia as well.

Now as a personal recommendation since your system is already broken, the Ubuntu installer includes Nvidia drivers, so I suggest you go for it instead this time, since you can change to a flavor anytime with

sudo apt-get install kubuntu-desktop

I don't know if the installers for the flavors are different, but Ubuntu's supported my card, it's what I can suggest. Good luck!

4
  • Enabling 3rd party drivers during the installation or using the command the OP mentioned - ubuntu-drivers autoinstall - does exactly the same thing you're suggesting here. Sep 22 at 22:11
  • I'm sorry, I didn't know they included proprietary drivers under that command. Cheers.
    – Santiago
    Sep 23 at 23:05
  • Nothing. For now I will try vanilla ubuntu and see if it's a plasma problem or something
    – Reimon42
    Sep 24 at 14:33
  • Alright as an update. Tried vanilla ubuntu. It didn't get stuck after grub and the scale was alright, but the micro-freezes/stuttering keeps happening. Forcing composition through nvidia didn't solve that either. Pain
    – Reimon42
    Sep 24 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.