13

I am trying to connect AirPods to Ubuntu 20.04 (Kernel : 5.11.0-36-generic), I read many blog posts, but nothing worked, whenever I try to connect, It tries to connect for sometime, and then the Settings App just freezes. Can anyone please help me? Pardon my bad English. Thank you.

Some blogs I read and followed (which didn't work) :

Setting up Airpods Pro on Ubuntu 20.04

How to pair+setup+connect airpod pro on ubuntu 20.04

Update: Issue resolved, see comment.

3

3 Answers 3

21

None of these and other solutions until I tried enabling SSPMode with

btmgmt ssp on

if this doesn't work try disabling it with

btmgmt ssp off

Note: you need sudo rights and you might need to turn off Bluetooth to switch settings.

4
  • 1
    This worked for me perfectly on ubuntu 21.04. Commented Dec 21, 2021 at 23:12
  • 1
    this worked for me on Pop_OS 21.04. Thank you.
    – DataPlug
    Commented Feb 7, 2022 at 23:40
  • 2
    Helped on Ubuntu 20.04. Thanks! Commented Apr 12, 2022 at 11:07
  • 1
    had the same problem, this was the only solution that worked for me! Commented May 13, 2022 at 0:45
11

For people trying to pair their AirPods max to ubuntu.

First, stop the Bluetooth service with:

sudo /etc/init.d/bluetooth stop
  1. Open the Bluetooth configuration file in a text editor, using the following command.
sudo vi /etc/bluetooth/main.conf
  1. add both bredr and dual mode to the Controller mode as follow:
ControllerMode = bredr
ControllerMode = dual

Then restart bluetooth

sudo /etc/init.d/bluetooth restart

You can now try to pair your device:

press and hold the noise control button for about five seconds, or until the status light flashes white

1
  • 1
    thanks man, switching it to bredr instead of dual made it work for me. could even revert the changes after pairing and it kept recognizing & connecting.
    – ppetermann
    Commented Jun 19, 2023 at 17:44
0

None of these solutions worked for me.

I followed this blog (ack aitos-dev), which works like a charm.

Basically, is modifying the ControllerMode under the Bluetooth configuration, so that it works in bedr mode. Then I restarted the Bluetooth service, and the AirPods were able to connect.

sudo vi /etc/bluetooth/main.conf

Find the next line:

#ControllerMode = dual

Change "dual" to "bredr". The final line must be:

ControllerMode = bredr

Restart the bluetooth service:

sudo /etc/init.d/bluetooth restart

Just to give more context, a quick differentiation between the allowed ControllerModes (dual, bredr, le):

  • ControllerMode = dual: Bluetooth controller supports both older and newer Bluetooth devices, offering compatibility and better performance, but it may consume more power.
  • ControllerMode = bredr: Bluetooth controller supports only older Bluetooth devices, ensuring compatibility with them and potentially saving power. It does not support newer Bluetooth devices with enhanced performance.
  • ControllerMode = le: Bluetooth controller operates exclusively in Bluetooth Low Energy (BLE) mode, supporting only BLE devices. This mode is suitable for applications that require low power consumption and are focused on BLE device interactions. It does not support older BR/EDR Bluetooth devices.

After the AirPods got connected, I could even revert the config to the original one, restart the Bluetooth service, and still be able to reconnect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .