8

Command prime-run outputs prime-run: command not found. I have Ubuntu 20.04.3 and nvidia-driver-470

2
  • 1
    What is prime-run? Also on my system the same... Looks like you have to add a repository
    – france1
    Commented Sep 20, 2021 at 14:43
  • I suppose you mean optirun from bumblebee package...
    – N0rbert
    Commented Sep 20, 2021 at 20:45

1 Answer 1

14

I have the same nvidia driver version and for some reason prime-run command does not exist.

I just solved it by doing the following:

  1. Copy contents of the gist here
    #!/bin/bash
    export __NV_PRIME_RENDER_OFFLOAD=1
    export __GLX_VENDOR_LIBRARY_NAME=nvidia
    export __VK_LAYER_NV_optimus=NVIDIA_only
    export VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json
    exec "$@"
    
  2. Create a file ~/bin/prime-run ("~" means your home directory)
  3. Paste the contents there.
  4. Run chmod +x "~/bin/prime-run" to make it executable.

You might want to re-open your terminal or restart your session so your terminal could recognize your ~/bin folder and be able to run prime-run command, that is, if the folder is not already there.

4
  • Nice workaround. prime-run was part of the proprietary nvidia drivers in the past. I assume that the command has been deprecated, for whatever reason and now removed.
    – jastram
    Commented Oct 14, 2021 at 6:07
  • I installed nvidia 510.60.02 with runfile and I don't have /usr/share/vulkan/icd.d/nvidia_icd.json. Is the file the same as /etc/vulkan/icd.d/nvidia_icd.json?
    – Gorgo
    Commented Apr 13, 2022 at 16:45
  • Thanks this worked with 535.54.03
    – cyrusbehr
    Commented Jul 31, 2023 at 18:54
  • @Gorgo probably, but why don't you install NVidia drivers from Ubuntu packages? That way you can be sure you can cleanly remove or upgrade them without having to manually clean up the file mess the non-ubuntu installer creates Commented Mar 24 at 3:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .