0

I have a Lenovo Thinkpad T450s with a trackpoint and a touchpad. Before upgrading to Ubuntu 21.04 I could disable the trackpoint on the terminal with the command

xinput set-prop "TPPS/2 IBM TrackPoint" "Device Enabled" 0

After the upgrade this does not work anymore and I get a message

WARNING: running xinput against an Xwayland server. See the xinput man page for details. unable to find device TPPS/2 IBM TrackPoint

Running

xinput list

shows that the device "TPPS/2 IBM TrackPoint" is not there anymore.

WARNING: running xinput against an Xwayland server. See the xinput man page for details. ⎡ Virtual core pointer
id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer
id=4 [slave pointer (2)] ⎜ ↳ xwayland-touch:17
id=9 [slave pointer (2)] ⎜ ↳ xwayland-relative-pointer:17
id=7 [slave pointer (2)] ⎜ ↳ xwayland-pointer:17
id=6 [slave pointer (2)] ⎣ Virtual core keyboard
id=3 [master keyboard (2)] ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)] ↳ xwayland-keyboard:17 id=8 [slave keyboard (3)]

If I attempt to disable any of the devices listed, it does not have the desired effect of disabling the trackpoint device. Is there a way to disable the trackpoint when using Ubuntu 21.04 from the terminal, preferrably without having to edit any configuration file and without having to reboot? If yes, how can this be done?

1 Answer 1

3

xinput only works on Xorg, this is what x stands for. But Ubuntu 21.04 switched to Wayland by default. Wayland provides a new command that is libinput. There's nothing special. libinput's configuration interface is available to the caller only, not directly to the user. That means you should write some C code that will include libinput libraries and call the functions by yourself. Then source that file somehow. Shortly, you can't easily do the same things that xinput can do.

In our case, the caller, is the Ubuntu itself, who cares about input device configuration that is possible using gnome settings. Unfortunately, these settings are global for all devices, i.e if you change the mouse speed, it will apply to all connected devices that can impact the cursor, so the trackpoint speed will also change.

If you really want to disable that trackpint on Wayland, you can try using a udev rule like:

ACTION=="add|change", KERNEL=="event[0-9]*", ENV{ID_VENDOR_ID}=="054a", ENV{ID_MODEL_ID}=="466a", ENV{LIBINPUT_IGNORE_DEVICE}="1"

you can retrieve the ID_VENDOR_ID and ID_MODEL_ID values using command:

udevadm info /dev/input/eventN

where N is the device number to ignore that you can obtain using command:

sudo libinput list-devices

(read more about ignoring devices on Wayland https://wayland.freedesktop.org/libinput/doc/latest/device-configuration-via-udev.html#ignoring-devices)

or you can switch back to Xorg and do whatever you want until the community implements things properly.

1
  • thanks for the switch back to Xorg reminder Dec 4, 2021 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.