4

I want to install Chaotica https://www.chaoticafractals.com/download on Ubuntu 20.04.2. It does not contain an installation instruction. There is a README, but it contains only license and thanks, nothing on installation or launching.

I've found several instructions for using tarballs with ./configure and make, but the unpacked folder does not contain a ./configure file. Then I found instructions using bin, but there is neither a bin folder nor a bin file in the unpacked tar. Are there other ways to install? Thanks!

3
  • Maye it would be better asking on their forum on the website.
    – Soren A
    Sep 20 at 8:52
  • The tar file is labelled on their site as "Archive", opposite to "Installer" that you have for example for Windows and MacOS version. So no installation at all - simply unpack to any directory and run.
    – raj
    Sep 20 at 23:05
  • @SorenA I've tried, but no answer.
    – Danny27
    Sep 23 at 5:28
4

On Microsoft Windows such applications are called portable.

So you can simply download the archive and then run main executable as follows:

cd ~/Downloads
wget -c https://www.chaoticafractals.com/dist/chaotica_x64_v2.0.36.tar.gz
tar -xf chaotica_x64_v2.0.36.tar.gz
cd chaotica_x64_v2.0.36
./chaotica

If you want to install it to, for example, /opt, then use commands below:

sudo mkdir -p /opt/chaotica
sudo cp -ar ~/Downloads/chaotica_x64_v2.0.36/* /opt/chaotica
sudo ln -s /opt/chaotica/chaotica /usr/local/bin/chaotica

And finally create desktop-file for it:

mkdir -p ~/.local/share/icons
cd ~/.local/share/icons
wget https://www.chaoticafractals.com/sites/all/themes/chaotica/favicon.ico -O chaotica.ico

mkdir -p ~/.local/share/applications/
cd ~/.local/share/applications/

cat <<EOF > chaotica.desktop # copy from this line to EOF, then paste
#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Type=Application
Icon=/home/$USER/.local/share/icons/chaotica.ico
Exec=chaotica
Name=Chaotica
EOF

and then launch it from dash/menu.

3
  • 1
    if you don't like the command line, you can presumably also just [double-]click on the file "chaotica" in the file browser to run it.
    – user253751
    Sep 20 at 21:31
  • @user253751 I've tried that (with and without executable bit) and it does not work. It asks with which application I want to open chaotica.
    – Danny27
    Sep 22 at 5:39
  • @N0rbert haven't had time to try, but looks very promising!
    – Danny27
    Sep 22 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.