Hello, thanks for responses.

I'm trying to install a plugin for gimp - its this one : https://sourceforge.net/projects/exportselectedlayersgimpplugin/

This is downloaded onto my second hard drive in a generic folder and I'm trying to move or copy and paste it into a gimp plugins folder like I used to do on windows.

What I've tried.

In gimp i have gone to edit/prefferences/folders/plugins

and found these two lines

/home/karribu/snap/gimp/372/.config/GIMP/2.10/plug-ins & /usr/lib/gimp/2.0/plug-ins

The first one doesn't let me copy and paste even when opened as admin. The second link doesn't lead anywhere and I get an error from ubuntu when i try to open as admin "oops something went wrong, unable to find the file"

I hope this is more clear than my post last night, thanks.

running 20.04.3 LTS

many thanks

  • I see a lot of frustration written, but not a lot of useful detail about exactly where the file is now, what user owns the file, what the permission of the file are, exactly where you want the file to be, and exactly which changes to ownership and permissions you want. Running Nautilus as root is not recommended, especially when frustrated or tired -- it's a great way to trash your system.
    – user535733
    Sep 19, 2021 at 2:18
  • ive updated my original question i hope its better Sep 19, 2021 at 16:46
  • just seen this. is it a problem with snap? forum.snapcraft.io/t/gimp-plugins-from-third-parties/8391/10 Sep 19, 2021 at 17:11
  • FYI, snaps tend to break external plugins due to the way they're sandboxed. Even as admin, you can't write to the snap because the snap is a static image that isn't writable - therein lies why you can't install the plugin. it's entirely possible that the fact that it's snapped breaks the ability to use external tools with the snapped form of GIMP.
    – Thomas Ward
    Sep 19, 2021 at 17:32
  • thanks for this - i installed a slightly older version via ppa but i still cant get the plugin to work. maybe the plugin is just too old? Sep 19, 2021 at 17:42

1 Answer 1


First, there may be no need for you to copy files as root in this case:

  • First check whether your plugin is not already packed in the gimp-plugin-registry package. Use Software or the command sudo apt install gimp-plugin-registry to install it. Remove it supplying remove in the above command`.
  • Alternatively, you can manually install plugins, but consider to do this as normal user. In Gimp, look up where plugins are stored in Edit - Preferences - Folders - Plugins. Among the folders, there will be one in your home directory as well (starting with /home/<yourlogin>/). Just copy plugins there: no root access needed.
  • If you need to copy to system locations, for example because you want the plugins to be available to all users of the system, then learn how to work with the admin:// URI.

So thus we come to your main question. To copy as administrator, open nautilus with a command (either in the terminal, or in the "Run" dialog you see after hitting Alt+F2):

nautilus admin:///app/lib/gimp/2.0/plug-ins

This opens the folder with admin privileges (note this is my plugins folder, corresponding with a flatpak install, yours may and likely will be different). Open a second nautilus window, and copy the files from that second window to that first one.

  • still cant copy and paste even as admin Sep 19, 2021 at 16:47
  • @vanadium this won't apply to snaps, which are specially sandboxed images. I don't believe this'll work for snaps. And we know OP is using the snapped version because of the paths they state.
    – Thomas Ward
    Sep 19, 2021 at 17:32
  • @ThomasWard We need specific information of course to provide specific answers. Still, also for snaps, plugins may be installed in the local profile. I think I provided concise information on how to obtain the path.
    – vanadium
    Sep 19, 2021 at 20:48
  • I followed your advice. Can get the plugin in folder but still doesnt show in gimp Sep 21, 2021 at 22:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .