0

I recently installed 'Ubuntu Desktop 21.04' on a sd card for my Raspberry Pi4b and while it seemed fine to start with after one or two reboots I get errors and wasn't able to boot back in again.

I tried again to flash the card with that same image and same thing happened. It was fine in the very first session but then I got this boot error that I haven't been able to solve.

The error message I kept getting was:

ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19

I read some comment saying it might be because of non-existing audio on the monitor but Iv'e successfully passed audio from HDMI->3.5mmjack out from the monitor under Raspbian OS.

I see some recent and some threads a few months old with people mentioning the same error messages. Often it leads to discussions involving Kodi. Seems to be some audio+hdmi related kernel thing?

Here's a recent and similar chat, https://github.com/raspberrypi/linux/issues/4575 another https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=316295

So last night I tried to find an older Ubuntu image and got a Ubuntu Mate 20.04.3. This has worked fine and I didn't get that error even after several reboots. It's using Kernel 5.4.

I also saw another user who reported a 'spontaneous reboot' which I suspect happened to me on my first try. (I wasn't in the room)

I can't use the older Ubuntu as I need the newer 'dma-buf' kernel updates that seem to be post 5.4.

Is there anyone who knows what this issue might be?

Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.