3

I'm on a MSI PE70 2QE Laptop with an NVIDIA Geforce GTX960M.

I was running Ubuntu 21.04 and since I've installed all the latest software updates my display is acting up.

It doesn't flicker but it's kind of squiggly looking interlacing or something (best description I could come up with :p).

I'm running a dual boot setup, and on Windows there's no problem, so I guess I can rule out the display being broken.

I've tried installing proprietary drivers (several of them), tried rolling back the updates and even uninstalled Ubuntu and installed Ubuntu 20.04 but the problem persists now.

Hope someone can help me out!


Some pictures of the problem (pictures are all taken during startup but the problem persists when in UI/OS as well): Image 1 Close enter image description here

6
  • 1
    Do you have problems with completely booted system?
    – N0rbert
    Sep 17 at 19:53
  • Yes the problem persists! Sep 17 at 19:56
  • Then please be more specific about laptop/desktop model, its video adapter and its driver.
    – N0rbert
    Sep 17 at 19:57
  • 1
    I'm on a MSI PE70 2QE Laptop with an NVIDIA Geforce GTX960M. I do not have any drivers at this time because the screens taken now are from running Ubuntu 20.04 from USB (Before installation). ALthough as i told in my initial question the problem was visible on (installed versions of) 21.04 20.04 with standard and latest proprietary drivers Sep 17 at 20:03
  • The MSI logo is independent of the OS, it appear before the OS is loaded. Whatever the problem is, there's no relation with Ubuntu. It's either hardware failure or some glitch in the firmware (UEFI). I don't understand why then you're posting this question and even less the bounty. Sep 19 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.