0

I have a Logitech C922 webcam which works but the microphone doesn't work. Settings does detect the microphone but I still can't get any sound and the mic bars don't move.

I tested the device on a windows laptop and it works fine.

My mainboard is an ASUS ROG Strix Z490-i

The system controls do detect the microphone. It is not suspended.

Here is the output from pcmd list-sources

index: 44
    name: <alsa_input.usb-046d_C922_Pro_Stream_Webcam_57E99BBF-02.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: RUNNING
    suspend cause: (none)
    priority: 9049
    volume: front-left: 56928 /  87% / -3.67 dB,   front-right: 56928 /  87% / -3.67 dB
            balance 0.00
    base volume: 9619 /  15% / -50.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max rewind: 0 KiB
    sample spec: s16le 2ch 32000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 1
    linked by: 1
    configured latency: 40.00 ms; range is 0.50 .. 2000.00 ms
    card: 4 <alsa_card.usb-046d_C922_Pro_Stream_Webcam_57E99BBF-02>
    module: 34
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "USB Audio"
        alsa.id = "USB Audio"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "1"
        alsa.card_name = "C922 Pro Stream Webcam"
        alsa.long_card_name = "C922 Pro Stream Webcam at usb-0000:00:14.0-9, high speed"
        alsa.driver_name = "snd_usb_audio"
        device.bus_path = "pci-0000:00:14.0-usb-0:9:1.2"
        sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.2/sound/card1"
        udev.id = "usb-046d_C922_Pro_Stream_Webcam_57E99BBF-02"
        device.bus = "usb"
        device.vendor.id = "046d"
        device.vendor.name = "Logitech, Inc."
        device.product.id = "085c"
        device.product.name = "C922 Pro Stream Webcam"
        device.serial = "046d_C922_Pro_Stream_Webcam_57E99BBF"
        device.form_factor = "webcam"
        device.string = "front:1"
        device.buffering.buffer_size = "256000"
        device.buffering.fragment_size = "128000"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analogue Stereo"
        device.description = "C922 Pro Stream Webcam Analogue Stereo"
        module-udev-detect.discovered = "1"
        device.icon_name = "camera-web-usb"
    ports:
        analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-input-microphone"
    active port: <analog-input-mic>
6
  • linux.org/threads/… Check this site guy had same problem, at the bottom of the question he says his was defective the new one works.
    – David
    Sep 13 at 14:08
  • There's no solution there. The camera works fine, only the microphone doesn't work.
    – mango
    Sep 13 at 15:17
  • Did you check installing pavucontrol? Sep 17 at 16:38
  • how is pavucontrol relevant to the microphone?
    – mango
    Sep 19 at 4:28
  • afaik pavucontrol, and paprefs are the most powerful gui audio applications in Ubuntu, unless you are up for installing jack2. The two of them combined let you do much of what you can do with CLIs like pacmd, pactl, etc.
    – Nate T
    Sep 19 at 6:55
2
+25

Based on the results from Linux-Hardware.org, this device should work with kernel versions 5.8 and above. That said, there are a number of people who have reported it works with Ubuntu 18.04 after unplugging and reconnecting, so your mileage may vary.

With this said, there are two things you will want to confirm:

  1. The webcam is being plugged into a USB3.x port (a USB 2.0 port will offer "some" of the functionality, but it must be plugged into a USB 3.x port to operate fully)
  2. The volume in Alsa Mixer is properly set. You can check this by opening a Terminal and typing alsamixer. You will see a screen that looks like this: AlsaMixer Use the and keys to navigate left and right to the microphone, then use the and keys to change the volume.

This may resolve the issue for you, so long as you are using an up-to-date version of Ubuntu 20.04 or newer.

3
  • Ports on this board are 3.x. Unlugging it does not work.
    – mango
    Sep 16 at 5:51
  • The settings in alsamixer made no difference. The OS is up to date
    – mango
    Sep 16 at 5:57
  • The link only lists video drivers. The mic would need to connect via its own Alsa driver, wouldn't it?
    – Nate T
    Sep 18 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.