CD tray has started opening by itself when I wake from suspend. I wouldn't usually regard as a big deal, but my case has a door on the front, and my CD is actually a DVD-RAM drive (not easily replaceable). Using 20.04 ws & kernel recently updated to 5.4.0-84. Has anyone else seen this and perhaps found a fix?

I'm guessing these folks down below that can't get their trays to open are thinking "Aaaw... whaaaa"!

That's all my search has yielded so far.


5 Answers 5


This happened with me yesterday as well. For what it's worth - I reverted back to kernel 5.4.0-81 (Advanced options for Ubuntu) and the problem disappeared. Of course this is just temporary and I will hope a newer kernel, other than 5.4.0-84, will solve the problem.


Updating Ubuntu Kernel solved the problem for me.

  1. Check your current kernel version

    $ uname -s r
    Linux 5.11.0-36-generic
  2. Update the Repositories

     $ sudo apt-get update
  3. Upgrade

    $ sudo apt-get dist-upgrade

The “dist-upgrade” switch asks Ubuntu to handle any dependencies intelligently. That is, if a particular software package is dependent on another software package to run, this command will make sure that the second package is upgraded before upgrading the first one.

This method is a safe way to upgrade your Ubuntu Linux kernel. The kernel updates accessible through this utility have been tested and verified to work with your version of Ubuntu.

  1. Check the updated kernel version

    $ uname -s r
    Linux 5.11.0-37-generic

Source: https://phoenixnap.com/kb/how-to-update-kernel-ubuntu


This is a problem users of other flavors are having. It is clearly a kernel bug.

Changing the BIOS order of OS search did not help, but leaving a CD in the player has stopped the opening on awaken for me.

Also, set the CD audio, DVD video, and Music player to "Do nothing." (Settings > Removable Media > CD audio to "Do nothing." Same for DVD video and Music player.) This way you don't get system activity and screen prompts on re-awaken.

I suspect the Linux programmers and maintainers work on laptops that don't have CD players, so it may take them a while to get motivated to fix this bug, especially since many system users don't use disk players.


Modify the file /lib/udev/rules.d/60-cdrom_id.rules:

ENV{DISK_EJECT_REQUEST}=="?*", RUN+="cdrom_id --eject-media $devnode", GOTO="cdrom_end"+#ENV{DISK_EJECT_REQUEST}=="?*", RUN+="cdrom_id --eject-media $devnode", GOTO="cdrom_end"

Then run:

systemctl restart udev.service

I can confirm the kernel update fix. Mine updated itself to, and I no longer have the problem. Thanks to everyone and especially kernel developers!

Mike Albert

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .