0

Kubuntu 20.04

Wifi: BCM43228 802.11a/b/g/n Driver manager function in Kubuntu system setting finds and install the driver for me automatically.

Symptom:

On DDWRT (Kernet 4.x) AP: All ssids can be connected without problem

On OpenWrt (v20.02, stable release, Kernel 5.x) AP: All ssids can't be connected, with error message "wlp2s0 can't be found". iwconfig shows wlp2s0 is there and active

If I boot the same PC into Windows 10, no problem connecting to all APs'ssids.

What could be the possible cause? Thank you.

8
  • That's very strange, but try disabling "Allow legacy 802.11b rates" which is found in the 2.4GHz Radio settings under Advanced Settings on your OpenWRT. It seems to me that once I turned that off on mine all my other things like Rokus and Google Chromecasts would now see each other on my network.
    – Terrance
    Sep 12, 2021 at 4:05
  • Thanks. I tried that you and still can't connect...strange
    – bthoven
    Sep 12, 2021 at 12:25
  • Maybe try installing the broadcom-sta-dkms package. I have seen around and people claim that installing the broadcom-sta package seemed to help their wireless chipset. Mind you, I am only guessing because I am not in your same situation and nor have I seen it. sudo apt install broadcom-sta-dkms.
    – Terrance
    Sep 12, 2021 at 13:43
  • Thanks. I tried installing broadcom-sta-dkms successfully, restart network manager, but still no luck.
    – bthoven
    Sep 13, 2021 at 5:56
  • Hmmm, I really have no idea. One last thing maybe try playing with the Operating Frequencies in OpenWRT, like I have mine set to N, (whatever channel recommend 1, 6 or 11 if in the US), 20MHz. Transmit power I leave at auto. It could honestly be a bug in the drivers for the Broadcom, but it is not unheard of out there where sometimes companies release updates and then peoples devices can no longer see certain WiFi SSIDs.
    – Terrance
    Sep 14, 2021 at 2:45

0

You must log in to answer this question.

Browse other questions tagged .