1

I used Ubuntu for about 2 weeks now and its great and everything, but somehow it stopped working when I turned my computer on this morning. For some reason I only see a black screen with a blinking underscore in the top left corner.

I was prompted to update Ubuntu (something along the lines of Ubuntu Core) yesterday so I'm confident that this update is responsible for that.

How do I resolve this? I spent quite some time setting up my machine and I would hate having to do everything again.

I already tried various things:

  • I can access a terminal when pressing CTRL+ALT+F2
  • I cannot access the grub menu, I tried various button combinations on boot, but nothing worked so far
  • I edited /etc/default/grub and added 'nomodeset' to GRUB_CMDLINE_LINUX_DEFAULT and after a reboot I got a working GUI, however at a bad resolution and only one of my monitors worked.
  • I tried service gdm3 --full-restart; systemctl gdm3 restart
  • I tried dpkg-reconfigure gdm3

Nothing really worked though. I use a NVidia GPU and it worked fine before the update, if thats important.

It would be great, if someone knew how to fix this problem, its really frustrating.

3
  • 1
    You mention many things that have made me a little confused; but you haven't given details of which kernel stack you're using (Ubuntu LTS releases offer two stack choices; GA or HWE). Maybe your fix is to use the GA stack (see wiki.ubuntu.com/Kernel/LTSEnablementStack and search for "To downgrade from HWE/OEM to GA kernel:". I'm assuming if you uname -r you'll see 5.11; and the issue occurred when you upgraded from 20.04.2 (5.8 kernel) to 20.04.3 (or 5.11 kernel).. I'm suggesting returning to the older but still supported 5.4 kernel or GA kernel stack.
    – guiverc
    Sep 9, 2021 at 13:32
  • 1
    @guiverc Sorry, but I'm fairly new to Linux and have never touched a kernel in my life, thats why I didn't mention any of that. But I fixed it now through 'reinstalling' the video driver, something was messed up there it seems. Thanks though!
    – Gereon99
    Sep 9, 2021 at 13:35
  • 1
    Well done for solving it yourself @Gereon99
    – guiverc
    Sep 9, 2021 at 13:37

1 Answer 1

0

Apparently I just fixed it. I looked into why 'nomodeset' kinda worked and showed me a GUI. As far as I understand 'nomodeset' prevents video drivers from being loaded.

I then tried to install a different video driver through the 'Additional drivers' application. I just used the open-source one. After a reboot (and removal of 'nomodeset') I was prompted with the GUI as it was before the update.

Then I installed the video driver I previously used (the recommended one) and after a reboot it still worked.

So something was wrong with the video drivers after performing an update, not sure what exactly thought, but maybe this helps other people out there.

1
  • 3
    Installing the nvidia-driver-XXX from the ubuntu-drivers autoinstall will install the NVIDIA drivers that will survive kernel updates as they contain DKMS (Dynamic Kernel Module Support) that pushes the drivers to be installed into each new kernel install.
    – Terrance
    Sep 9, 2021 at 13:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .