0

I'm using livepatch on Ubuntu 18.04 LTS for quite some time. A few days ago I noticed a red exclamation mark. Then I signed out and tried to reapply the live patch.

However the following comand throws an error:

sudo canonical-livepatch enable <key>
--> error executing enable: failed to register client: Post https://livepatch.cannonical.com/v1/client/<key>?test=: x509: certificate signed by unknown autority.

How can succesfully enable live patch again? Thanks for your help!

5
  • When was the last time you updated the server manually? If your system is suffering from this bug, then a fix was released last August 🤔
    – matigo
    Sep 8 '21 at 8:51
  • when SW update show up in grahical client I always apply them asap. Currently graphical client doesn't show any pending updates. Should I do anything else?
    – ssssstut
    Sep 8 '21 at 8:54
  • Did you type that error yourself? The URL should begin with https://livepatch.canonical.com/v1/client/ (single n in canonical).
    – muru
    Sep 8 '21 at 8:57
  • yes, it's my typo. Thanks for mentioning it. I just now tried apt-get update and apt-get upgrade and then sudo canonical-livepatch enable <key> --> same error. So system should be up to date.
    – ssssstut
    Sep 8 '21 at 8:59
  • Is it an issue with my ubuntu installation or should I register online for a new livepatch key?
    – ssssstut
    Sep 8 '21 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.