1

Recently, I've been trying to install and setup a Synology NAS server (DS920+) on our Ubuntu server (18.04) at work, and I am facing some connection issues with the wired connection (ethernet connection connecting NAS to the server). The connection status shows that it's trying to connect as seen in the figure here [connection status][1]

But after a while it changes to connection "Disconnected" as seen in here [Ethernet Network Disconnected][2]

I have tried a few solutions posted on stack exchange and on different boards but none that I have tried so far have worked.

Here are the outputs of some of the commands that might be useful from what I understand:

input:

lspci | grep -i eth

output:

04:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)
05:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)
83:00.0 Ethernet controller: Aquantia Corp. AQC107 NBase-T/IEEE 802.3bz Ethernet Controller [AQtion] (rev 02)

input:

ifconfig -a

enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
ether ac:1f:6b:b0:88:4a txqueuelen 1000 (Ethernet)
RX packets 42848 bytes 25213836 (25.2 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 180780 bytes 34482983 (34.4 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device memory 0xce200000-ce27ffff

enp5s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether ac:1f:6b:b0:88:4b txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device memory 0xce100000-ce17ffff

ens6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 172.16.43.69 netmask 255.255.255.0 broadcast 172.16.43.255
inet6 fe80::1bef:699c:49b:e845 prefixlen 64 scopeid 0x20
ether 40:b0:76:58:42:11 txqueuelen 1000 (Ethernet)
RX packets 2084658 bytes 216239936 (216.2 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 130491 bytes 46668382 (46.6 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 230369 bytes 18799477 (18.7 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 230369 bytes 18799477 (18.7 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

input:

sudo lshw -C network

output :

*-network
description: Ethernet interface
product: I210 Gigabit Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: enp4s0
version: 03
serial: ac:1f:6b:b0:88:4a
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.6.0-k duplex=full firmware=3.16, 0x800004d9 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:18 memory:ce200000-ce27ffff ioport:6000(size=32) memory:ce280000-ce283fff
*-network
description: Ethernet interface
product: I210 Gigabit Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:05:00.0
logical name: enp5s0
version: 03
serial: ac:1f:6b:b0:88:4b
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.6.0-k firmware=3.16, 0x800004d9 latency=0 link=no multicast=yes port=twisted pair
resources: irq:19 memory:ce100000-ce17ffff ioport:5000(size=32) memory:ce180000-ce183fff
*-network
description: Ethernet interface
product: AQC107 NBase-T/IEEE 802.3bz Ethernet Controller [AQtion]
vendor: Aquantia Corp.
physical id: 0
bus info: pci@0000:83:00.0
logical name: ens6
version: 02
serial: 40:b0:76:58:42:11
size: 10Gbit/s
capacity: 10Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pciexpress pm msix msi bus_master cap_list rom ethernet physical tp 100bt-fd 1000bt-fd 10000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=atlantic driverversion=5.4.0-81-generic-kern duplex=full firmware=3.0.33 ip=172.16.43.69 latency=0 link=yes multicast=yes port=twisted pair speed=10Gbit/s
resources: irq:44 memory:fb840000-fb84ffff memory:fb850000-fb850fff memory:fb400000-fb7fffff memory:fb800000-fb83ffff

The connection in question is enp4s0. The connection can support up to 1Gbit/s and the cable is rated for 100Mbit/s, my understanding is that shouldn't cause a problem and should only bottleneck the speed to 100Mbit/s.

Update: I have replaced the cable with a 1Gbit/s cable and set the link negotiation to Manual with speed set at 1Gbit/s, using the Network Manager GUI. No change in the issue.

I've also tried different ports to see if that's the problem (both on the server and on the NAS).

Any help would be greatly appreciated, I'm a bit new at this since our original server admin left recently, so please let me know if you require any additional information and I'll try to provide them.

Thanks! [1]: https://i.stack.imgur.com/iU7kb.png [2]: https://i.stack.imgur.com/2LiIm.png

3
  • 1
    The problem is your 100Mb cable. enp4s0 is still connecting at 1Gb.
    – heynnema
    Sep 7, 2021 at 16:34
  • Speed negotiation is between the switchport and the ethernet adapter, not your cable. Your cable is causing the bottleneck which will affect your configurations. Manually set the connection speed on your interface to 100Mbps and that should 'fix' the disconnection bottlenecks caused by your cables by telling the system the max it can talk over that cable is 100Mbps. Or, alternatively, purchase a standard Cat5E or Cat6 cable, which supports full gigabit (the current Ethernet cable standards are Cat5e and Cat6 currently, and anything older than Cat5e is considered 'obsolete')
    – Thomas Ward
    Sep 7, 2021 at 16:40
  • Are you using a GUI or the command line to set up your network interface?
    – Thomas Ward
    Sep 7, 2021 at 16:46

1 Answer 1

1

Port speed negotiation is typically done between the ethernet port at both ends, NOT at the cable level. So while your cable will bottleneck you to 100Mbps, your system detects a gig endpoint at the other end and as such your obsolete Cat5 cable is causing the disconnects because your system is trying to push gig over the unsuitable cable, causing network timeouts and huge congestion at the network stack levels.

Either upgrade your obsolete 100Mbps cable to a standard Cat5E cable (Cat5E is pretty dirt cheap nowadays since it's the oldest standard still supported and commonly encountered nowadays) or to a Cat6 cable, or manually set the speed on your ethernet adapter. Depending on how you configure your networking (GUI or command line) will determine the process you use to set negotiation speeds.

(Depending on your answer to the question I asked in comments on the core question, this answer will adapt to how to set the link negotiation speed manually based on your response)

5
  • Thank you for the reply. I changed the cable to a CAT5e (don't currently have a CAT6 - I do have a 10Gb/s cable), also set the link negotiation to Manual (it was previously set to Auto) and changed the speed to 1Gb/s in the network editor GUI. I still have the same issue.
    – rozTsoni
    Sep 7, 2021 at 17:39
  • @rozTsoni normally you would connect the NAS to your network and your computer to the network not directly NAS-to-Server unless it's an iSCSI type connection or such. Are you connected directly to the NAS over ethernet and setting static connection data on a separate subnet from the rest of your network? We need to see more about how you're configuring things.
    – Thomas Ward
    Sep 7, 2021 at 21:39
  • It is connected to a network hub, I'm starting to think there might be a firewall preventing the connection. I'm not authorized to tinker with that so I will be testing a separate network hub to see if that's the issue. I will get back with the results. Thank you for your help so far!
    – rozTsoni
    Sep 8, 2021 at 18:09
  • @rozTsoni "hubs" are retired in favor of routers because "hubs" just rebroadcast everything and can cause data loops and overloads of pipes. If you aren't using a switch, then you should be focusing entirely on whether these systems are on separate subnets or the same subnets - if they're the same subnets then your system firewalls are going to be at play, if they're different then it's the firewalls likely, and you can't do anything with that.
    – Thomas Ward
    Sep 8, 2021 at 18:20
  • Just an update to the problem: I used a network switch and had the NAS and our server both attached to the switch. Initially, the problem persisted, but then in the network editor, under IPv4 Settings, I changed the Method to Link-Local Only and now things seem to be working well. Thanks for all the help!
    – rozTsoni
    Sep 20, 2021 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.