5

When I open sound settings, No profile options are listed for "Built-in audio" except for "Off".

Machine is a Acer Chromebook Spin 713 with MrChromeBox coreboot firmware and Ubuntu MATE 21.04 installed (however, issue also exists with Lubuntu 20.04.3). Laptop has built-in speakers and a 3.5mm audio jack, but does not recognize any playback audio devices except HDMI.

Sound Device: 00:1f.3 Multimedia audio controller: Intel Corporation Comet Lake PCH-LP cAVS DeviceName: Multimedia audio controller Subsystem: Intel Corporation Comet Lake PCH-LP cAVS Flags: bus master, fast devsel, latency 64, IRQ 148 Memory at 9fa14000 (64-bit, non-prefetchable) [size=16K] Memory at 9f900000 (64-bit, non-prefetchable) [size=1M] Capabilities: Kernel driver in use: snd_hda_intel Kernel modules: snd_hda_intel, snd_sof_pci

alsa-info output: http://alsa-project.org/db/?f=7d8c2e0f06a902f817c71fdf4aae1f16e7b21227

Note: I have made one modification to /etc/modprobe.d/alsa-base.conf, adding the following line: "options snd-hda-intel dmic-detect=0" Before this, the laptop's sound card was not being recognized at all.

alsa-info output from before: http://alsa-project.org/db/?f=3c348ee95fa38bceb3f25e38e4de431766f808c8

4
  • What error messages when running sudo dmesg | grep audio command?
    – J.T.
    Commented Dec 22, 2021 at 1:55
  • I have the exact same issue, but I have an Samsung Galaxy Chromebook Go 14" (Jasper Lake intel chip) that I loaded with MrChromebox RW_LEGACY firmware, and I now run Ubuntu 22.04. Audio only works over HDMI, not 3.5mm jack nor internal speakers (the device is listed as "Dummy Driver" in the sound settings). sudo dmesg | grep audio lists: [ 3.653584] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915]), so the driver appears to be working fine. Commented Apr 30, 2022 at 6:20
  • Duplicate of askubuntu.com/q/1448750/124466 Commented Apr 11 at 2:35
  • Does this answer your question? How to install Chromebook audio drivers in Ubuntu?
    – karel
    Commented Apr 11 at 9:30

1 Answer 1

0

Credits: https://github.com/WeirdTreeThing/chromebook-linux-audio

This worked for me on Ubuntu 24.04 (development branch). You'll need to erase the Python function that searches for Ubuntu and stops the process if it is found. The function is called ubuntu(). This is in the setup-audio file. Open this file with your text editor of choice. A link to the image that shows which is the function you'll need to erase is found at the end of this answer. Make sure to also erase any other lines that call this function. After you finish, run the setup-audio file in your terminal. Then reboot. You should have sound now.

This is known to work on Ubuntu 23.10 and later releases.

More on: How to install Chromebook audio drivers in Ubuntu?

Image: https://i.sstatic.net/KyNPh0Gy.png


Another solution:

Credits: https://gist.github.com/jeremy-breidenbach/92fc648ed2590ff9cd3a0ae57ed98e4a

This has also worked for me in Ubuntu 24.04, since I had to reset my installation and I had to reinstall all the drivers again.

Download the "asound.state" file. Kill all the audio services with sudo alsa force-unload. After, run sudo cp ~/Downloads/asound.state /var/lib/alsa to replace the system's sound config file with the "asound.state" file. Then reboot. You should have sound.

2
  • You should upgrade your Ubuntu release if you want to make the sound card work.
    – E.S
    Commented Apr 11 at 2:26
  • Please add more details about how to erase the python function Commented Apr 11 at 2:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .