0

I am using Displaylink driver to use my Dell D3100 dock for my 2 external monitors. But in my sound profile, whenever I boot my laptop or disconnect from my headphones, my computer reverts to the Dock audio as its default audio output device. Its incredibly annoying. I don't want to demove my Displaylink driver as a result but how can I get rid of this?

~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Dock [Dell D3100 USB3.0 Dock], device 0: USB Audio [USB Audio] <-- This is the problem
  Subdevices: 1/1
  Subdevice #0: subdevice #0

2 Answers 2

0

I have an alternative solution that might help you. I presume you are using Gnome. You may try the Gnome shell extension Sound input and output device chooser. In the settings of the extension, you have the option to hide the devices.

1
  • I am using wayland on 21.04
    – oo92
    Sep 7, 2021 at 3:24
0

You could try setting the default sound device with something like How do you set a default audio output device in Ubuntu 18.04?

  1. Run: pactl list short sinks
  2. Note the device name you want to use as default
  3. Try to run: pactl set-default-sink <Your_Device_Name>. This should work without giving you an error message.
  4. Open the application "Startup Applications" (Should be preinstalled on Ubuntu)
  5. Click on "Add"
  6. Give your startup item a name
  7. Copy your command from above into the command field: pactl set-default-sink 'Your-Device-Name'
  8. Click on "Save".

pactl list short sources and pactl set-default-source <Your_Device_Name> may also be needed.

As per this answer, it may also work editing /etc/pulse/default.pa to add

### Make some devices default
set-default-sink <Your_Device no. or name>
set-default-source <Your_Device no. or name>

Perhaps the possible change in numbers mentioned in the answers in the link force the need for a name. And you may need to comment line load-module module-switch-on-connect prepending a #.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.