0

I think the problem is -- to Ubuntu, it doesn't seem that some of the files are executable at all or rather it doesn't know its file to type. The Files Manager due to which instead of showing the original icon (let's say the Arduino icon in this case) always tends to show some sort of unexecutable icon (as is visible in the attached image) for almost every (downloaded) file/program.

So, when I double click the file (say Arduino-ide) I get the message 'there is no application installed for "shared library" files.'

Note 1: I can mostly run the files/programs from the terminal with ./ and it works mostly correctly but that's not the permanent solution at all.

So, is it because some application/package is missing since I've done minimal installation of Ubuntu?!

Note 2: I've already tried chmod +x, chmod 777, and permissions tab of file's properties in Files (which probably uses chmod anyway) but nothing seemed to work.

Note 3: Also, for the (unreadable) icon problem, I've tried creating Desktop Entry (altering Exec, Path, Icon in the new, created text file) as was suggested in some of the other answers but that didn't work as well.

Here's the image enter image description here

Note 4: I know a few other similar questions exist but none of them have been able to resolve my situation as of now.

1
  • Have you tried to go to Edit → Preferences → Behavior and toggle Executable Text Files to Ask each time as described in this answer?
    – mchid
    Sep 5, 2021 at 10:12

1 Answer 1

0

Execute the file using terminal.

user@ubuntu:~/Applications/arduino-ide_2.0.1_Linux_64bit$ ./arduino-ide
1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 2, 2022 at 10:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .