0

I installed clipit by following the instructions on this page for Ubuntu (https://github.com/CristianHenzel/ClipIt#on-ubuntu) so I used the command sudo apt-get install build-essential git automake xdotool autoconf intltool autopoint gtk+-3.0 and then

tar zxvf clipit-x.y.z.tar.gz
cd clipit-x.y.z
./autogen.sh
./configure --with-gtk3 
make
sudo make install

It was not showing up on the dash and I was not able to perform any modifications on its settings through preferences or any other options. So, I uninstalled it with sudo apt-get purge clipit and then sudo apt-get autoremove I also tried remove command but it seems nothing worked and it still is usable and being shown when I search for it.

I also tried to remove it from ubuntu software but it didn't show remove but showed the button to install. I tried the command dpkg --list to see if clipit was there before starting any procedure for uninstalling but it didn't show there before and after. H

How can I uninstall clipit completely without any trace?

Edit: This answer helped me solve this problem: https://askubuntu.com/a/71245/1416525

It seems that you can't remove apps from the Dash, however you can manage your launchers (*.desktop files) in one of the following directories: /usr/share/applications /usr/local/share/applications ~/.local/share/applications If your launcher file is in any of the first two directories, you will require root permissions to remove it.

3
  • 2
    You built clipit from source, you didn't install it with apt, so you shouldn't expect that removing it with apt would work. Commented Sep 4, 2021 at 17:23
  • 1
    Try sudo make uninstall. If you installed via Makefile, you have to uninstall it via Makefike.
    – waltinator
    Commented Sep 4, 2021 at 17:27
  • 1
    What was wrong with packages.ubuntu.com/focal/clipit ? Why do you make Ubuntu to act like Gentoo or LFS?
    – N0rbert
    Commented Sep 4, 2021 at 18:57

3 Answers 3

1

For your case uninstall via apt will not work. You need to remove clipit from /usr as while installation it default get installed there. You can find all clipit files and remove it by below command.

sudo find / -name "clipit" -delete
1
1

Apt is not magical. Apt can only uninstall deb packages. Not Snaps, not Flatpaks, not Pip Wheels, not software compiled from source (that's what you did), not anything else.

So apt can uninstall build-essential git automake xdotool autoconf intltool autopoint gtk+-3.0 -- those are the prerequisites that you installed.

But apt cannot undo a make install. That's not a deb package.

  • Review your install instructions. Perhaps there were uninstall instructions.

  • Review the makefile. Maybe there is a make uninstall defined. Alternately, folks who are skilled at reading the makefile (not too difficult, try it!) can figure out which files were installed and manually delete those files.

  • If there are no uninstall instructions at all, anywhere (including the upstream GitHub source), then open an issue on GitHub: Ask the author for uninstall instructions or a makefile uninstall.

  • Reminder: If you really care about the software, and the license is compatible, you can package the software as a Deb or Snap. With a compatible license, you don't need anybody's permission. Then the software CAN be removed by existing package tools, and the entire community can benefit from the software.

1
  • Yes, it's almost always sudo make uninstall.
    – mchid
    Commented Sep 5, 2021 at 6:25
1

If you only used apt to install it then
sudo apt-get purge clipit*
note the asterix

1
  • 1
    The author of the question installed clipit from source.
    – karel
    Commented Sep 6, 2021 at 7:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .