2

I just got a new Chuwi Gemibook Pro and installed Linux Ubuntu 21.04 on it, and there is no sound. In “Output device” I see only Dummpy output, and after adding options snd-hda-intel model=generic in /etc/modprobe.d/alsa-base.conf it changed to “HDMI / Display Port - Built-in Audio” but it still doesn’t work. I tried different kernels (5.10, 5.11, 5.13) - all the same. Unfortunately I removed Windows before checking the sound so I don’t know is it a hardware problem or not.

Here is some information, please ask if you need more:

 $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: Generic Digital [Generic Digital]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
 $ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xa1210000 irq 129
 $ cat /proc/asound/card0/codec#2 | grep -i codec
Codec: Intel Generic
 $ lspci -nn | grep -i audio
00:0e.0 Multimedia audio controller [0401]: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio [8086:3198] (rev 06)

Updates of info:

Results of alsa-info script: http://alsa-project.org/db/?f=317f3dceef73b34b71e326ba96a55f9dd4e8206c

$ lsmod | grep snd
snd_hda_codec_hdmi     61440  1
snd_sof_pci_intel_apl    16384  0
snd_sof_intel_hda_common    98304  1 snd_sof_pci_intel_apl
snd_soc_hdac_hda       24576  1 snd_sof_intel_hda_common
soundwire_intel        40960  1 snd_sof_intel_hda_common
snd_sof_intel_hda      20480  1 snd_sof_intel_hda_common
snd_sof_pci            20480  2 snd_sof_intel_hda_common,snd_sof_pci_intel_apl
snd_sof_xtensa_dsp     16384  1 snd_sof_intel_hda_common
snd_sof               135168  2 snd_sof_pci,snd_sof_intel_hda_common
ledtrig_audio          16384  1 snd_sof
snd_soc_skl           163840  0
snd_soc_sst_ipc        20480  1 snd_soc_skl
snd_soc_sst_dsp        32768  1 snd_soc_skl
snd_hda_ext_core       32768  4 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_soc_acpi_intel_match    49152  3 snd_sof_intel_hda_common,snd_soc_skl,snd_sof_pci_intel_apl
snd_soc_acpi           16384  3 snd_soc_acpi_intel_match,snd_sof_intel_hda_common,snd_soc_skl
snd_soc_core          290816  5 soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl
snd_compress           28672  1 snd_soc_core
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_hda_intel          53248  1
snd_intel_dspcfg       28672  3 snd_hda_intel,snd_sof_intel_hda_common,snd_soc_skl
snd_intel_sdw_acpi     20480  2 snd_sof_intel_hda_common,snd_intel_dspcfg
snd_hda_codec         147456  3 snd_hda_codec_hdmi,snd_hda_intel,snd_soc_hdac_hda
snd_hda_core           94208  8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               118784  11 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_compress,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
snd_seq_midi           20480  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            36864  1 snd_seq_midi
snd_seq                73728  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_timer              40960  2 snd_seq,snd_pcm
snd                    94208  13 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_rawmidi
soundcore              16384  1 snd
$ inxi -SA
System:
  Host: sul-GemiBook-Pro Kernel: 5.13.13-051313-generic x86_64 bits: 64 
  Desktop: GNOME 3.38.4 Distro: Ubuntu 21.04 (Hirsute Hippo) 
Audio:
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.13.13-051313-generic 
$ lspci -nnk |grep -A 1 Audio
00:0e.0 Multimedia audio controller [0401]: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio [8086:3198] (rev 06)
    DeviceName: Onboard - Sound
$ uname -a
Linux sul-GemiBook-Pro 5.13.13-051313-generic #202108261440 SMP Thu Aug 26 14:50:08 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
$ sudo lshw -C multimedia
  *-multimedia              
       description: Multimedia audio controller
       product: Celeron/Pentium Silver Processor High Definition Audio
       vendor: Intel Corporation
       physical id: e
       bus info: pci@0000:00:0e.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:129 memory:a1210000-a1213fff memory:a1000000-a10fffff
  *-usb:1
       description: Video
       product: USB 2.0 Camera
       vendor: Sonix Technology Co., Ltd.
       physical id: 6
       bus info: usb@1:6
       version: 1.00
       serial: SN0001
       capabilities: usb-2.00
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
$ dpkg -l | grep alsa
ii  alsa-base                                   1.0.25+dfsg-0ubuntu7                                                 all          ALSA driver configuration files
ii  alsa-topology-conf                          1.2.4-1                                                              all          ALSA topology configuration files
ii  alsa-ucm-conf                               1.2.4-2ubuntu1.2                                                     all          ALSA Use Case Manager configuration files
ii  alsa-utils                                  1.2.4-1ubuntu3                                                       amd64        Utilities for configuring and using ALSA
ii  gstreamer1.0-alsa:amd64                     1.18.4-1                                                             amd64        GStreamer plugin for ALSA
$ grep intel /etc/modprobe.d/alsa-base.conf 
options snd-intel8x0m index=-2

Output for kernel modules was too large, so I posted it here: https://pastebin.com/AtCTKn7F

Will be grateful for any help, Thank you

5
  • Please check askubuntu.com/questions/1258510/… and take the time to post the extensive set of info listed. Commented Sep 1, 2021 at 20:57
  • Thanks, I tried to reproduce all the info from the post, please check
    – Sul
    Commented Sep 1, 2021 at 22:03
  • There is a thread in the MX Linux Forum. Most likely, it is not a hardware fault as it affects multiple people in multiple distros. Commented Sep 3, 2021 at 5:54
  • I have the same problem with Zorin OS 16, I tried some solutions that I found on the internet but still have no audio. It looks like you have made much more research to solve the problem. My solution is to use Bluetooth headphones and they works fine. Commented Sep 5, 2021 at 15:43
  • Bluetooth headphones is an option, but my microphone isn't working as well, and it's hard to make the microphone from the headphones work along with them. I want to try USB garniture
    – Sul
    Commented Sep 5, 2021 at 18:29

1 Answer 1

1

It is not hardware, as I am having the exact same issue on a Gemibook Pro, although on another distro, and there is a open bug on sof project. Even though that bug is initially for the Hi10X tablet, it is directly applicable to the gemibook pro, as it apparently has the same sound hardware, the ES8336 codec - [BUG] No local devices (speakers/headphones) on N4120 tablet (Chuwi Hi10X) #2955; there is a pull request linked at the end of the bug which indicates that support will come as soon as a driver is cleaned and pushed upstream. You can probably try it out by following the instructions for setting up a ktest environment and the pull request itself.

3
  • Thank you, I hope their fix will help, applying it by myself seems too hard. I wonder, do you have sound problems with Windows or it's just Linux?
    – Sul
    Commented Sep 7, 2021 at 12:16
  • It would be great if someone who knows how to compile this patch posts a step by step solution. Commented Sep 7, 2021 at 13:07
  • In windows sound works without issues. As for working code and documentation, they are in the sof github - the pull request has the code (github.com/thesofproject/linux/pull/2962) and the github wiki has the documentation, in this case the relevant one is the setting up the ktest environment - thesofproject.github.io/latest/getting_started/setup/…. I can copy it here but it would be redundant and subject to drift from the source.
    – JBernardo
    Commented Sep 7, 2021 at 14:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .