22

I've been trying to set up an external monitor for a bit, finally got it mostly working except the resolution is off. My monitor's native res is 1600x900, which I finally got to show up in xrandr:

user:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1600 x 900
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0* 
   800x600         0.0  
   640x480         0.0  
   1600x900       59.9

However when I try to change the resolution I get the following error:

user:~$ xrandr --output default --mode 1600x900
xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed
  • 2
    The crtc is a part of your graphics adapter that decides what pixels should be what color as your screen is painted on your monitor (it does all of the timing)--so this may mean that though you monitor may be able to use this mode, your graphics adapter can't. It might be helpful to know about your equipment, the contents of /var/log/Xorg.0.log, and know what you had to do to get that resolution into xrandr's display. The other 0.0 displays look strange, by the way. – John S Gruber May 19 '12 at 3:15
9

I found that problem with ATI video drivers, with deactivated driver all works.

Use

xrandr --verbose

to determine your ctrtc number? And try correct output syntax, e.g.:

xrandr --output CRT1 --crtc CRT1 --brightness 0.7

other outputs:

  • the Intel driver uses LVDS, VGA, TMDS-1 (TMDS-2, ...), TV
  • the ATI driver uses LVDS, VGA-0 (VGA-1, ...), DVI-0 (DVI-1, ...), S-video
  • the RadeonHD driver uses PANEL, VGA_1 (VGA_2, ...), DVI-I_1/digital or DVI-I_1/analog (DVI-I_2/digital or DVI-I_1/analog, ...), TV_7PIN_DIN
  • the NV driver uses LVDS, VGA0 (VGA1, ...), DVI0 (DVI1, ...), ???
  • the MGA driver uses ???, VGA (or VGA1, VGA2, ...), DVI (or DVI1, DVI2, ...), ???
  • the Nouveau driver uses LVDS, VGA-1, DVI-I-1, HDMI-1, ???
  • 3
    "error: crtc must be used after output" And even specifying the CRTC shows by xrandr, I still get the error "Configure crtc 0 failed" – Cerin Apr 22 '15 at 4:54
  • 2
    Agreed. You have to specify the output first: "xrandr --output CRT1 --crtc CRTCNUMBER --brightness 0.7". As to why this didn't work for you, however, no clue. – BobDoolittle Dec 15 '15 at 6:12
5

xrandr --verbose was very helpful to me. i managed to create a few scripts to help out with my buggy docking station situation. i want docked to be only external display, undocked to mean only laptop.

xrandr -d :0 --output eDP1 --mode 1920x1080 --crtc 1 \
    --output DP1-1 --off \
    --output DP1-2 --off \
    --output DP1-3 --off

and also...

xrandr -d :0 --output DP1-1 --mode 1920x1080 --crtc 1 \
    --output eDP1 --off \
    --output DP1-2 --off \
    --output DP1-3 --off
2

First, you need to disable WAYLAND by uncommenting a line in file:

/etc/gdm3/custom.conf  

the above file may be in some other folder name variation of gdm. Remove the # in front of the line

#WaylandEnable=false 

Reboot your Linux.

After that, run the xrandr command. You will not find WAYLAND0. You will find DP1, HDMI1, VGA1, etc... instead.

Now, you can use xrandr to change display resolution normally. Follow the same process you were doing earlier.

  • 3
    This "#WaylandEnable=false" will break your whole Unity GUI. Never do it. – medina Dec 4 '18 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.