I've been trying to set up an external monitor for a bit, finally got it mostly working except the resolution is off. My monitor's native res is 1600x900, which I finally got to show up in xrandr:

user:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1600 x 900
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0* 
   800x600         0.0  
   640x480         0.0  
   1600x900       59.9

However when I try to change the resolution I get the following error:

user:~$ xrandr --output default --mode 1600x900
xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed
  • 3
    The crtc is a part of your graphics adapter that decides what pixels should be what color as your screen is painted on your monitor (it does all of the timing)--so this may mean that though you monitor may be able to use this mode, your graphics adapter can't. It might be helpful to know about your equipment, the contents of /var/log/Xorg.0.log, and know what you had to do to get that resolution into xrandr's display. The other 0.0 displays look strange, by the way. May 19, 2012 at 3:15

3 Answers 3


I found that problem with ATI video drivers, with deactivated driver all works.


xrandr --verbose

to determine your ctrtc number? And try correct output syntax, e.g.:

xrandr --output CRT1 --crtc CRT1 --brightness 0.7

other outputs:

  • the Intel driver uses LVDS, VGA, TMDS-1 (TMDS-2, ...), TV
  • the ATI driver uses LVDS, VGA-0 (VGA-1, ...), DVI-0 (DVI-1, ...), S-video
  • the RadeonHD driver uses PANEL, VGA_1 (VGA_2, ...), DVI-I_1/digital or DVI-I_1/analog (DVI-I_2/digital or DVI-I_1/analog, ...), TV_7PIN_DIN
  • the NV driver uses LVDS, VGA0 (VGA1, ...), DVI0 (DVI1, ...), ???
  • the MGA driver uses ???, VGA (or VGA1, VGA2, ...), DVI (or DVI1, DVI2, ...), ???
  • the Nouveau driver uses LVDS, VGA-1, DVI-I-1, HDMI-1, ???
  • 5
    "error: crtc must be used after output" And even specifying the CRTC shows by xrandr, I still get the error "Configure crtc 0 failed"
    – Cerin
    Apr 22, 2015 at 4:54
  • 3
    Agreed. You have to specify the output first: "xrandr --output CRT1 --crtc CRTCNUMBER --brightness 0.7". As to why this didn't work for you, however, no clue. Dec 15, 2015 at 6:12
  • Ensure you specify the crtc number, especially if you're disconnecting and reconnecting different external monitors outputs at different points in time (e.g., one monitor via VGA at home and another monitor via HDMI at work).
    – dat
    Aug 3, 2020 at 17:57
  • @Cerin - my usb-c connector did not manage higher frequency than 30hz, therefore I got always that crtc 0 failed error, as soon as I configured it for that lower frequency - it worked. Inspiration - askubuntu.com/questions/1053646/…
    – FantomX1
    Sep 12, 2021 at 23:04

First, you need to disable WAYLAND by uncommenting a line in file:


the above file may be in some other folder name variation of gdm. Remove the # in front of the line


Reboot your Linux.

After that, run the xrandr command. You will not find WAYLAND0. You will find DP1, HDMI1, VGA1, etc... instead.

Now, you can use xrandr to change display resolution normally. Follow the same process you were doing earlier.

  • 9
    This "#WaylandEnable=false" will break your whole Unity GUI. Never do it.
    – medina
    Dec 4, 2018 at 11:02
  • This worked for me on a VM where my output was set as WAYLAND0. Of course, no big loss if it screwed up so I tried it but thanks!
    – Amit Patel
    Oct 18, 2022 at 20:40
  • This works just fine. Granted I run Debian, not Ubuntu and use Gnome3.
    – E.T
    Jun 13, 2023 at 16:38

xrandr --verbose was very helpful to me. i managed to create a few scripts to help out with my buggy docking station situation. i want docked to be only external display, undocked to mean only laptop.

xrandr -d :0 --output eDP1 --mode 1920x1080 --crtc 1 \
    --output DP1-1 --off \
    --output DP1-2 --off \
    --output DP1-3 --off

and also...

xrandr -d :0 --output DP1-1 --mode 1920x1080 --crtc 1 \
    --output eDP1 --off \
    --output DP1-2 --off \
    --output DP1-3 --off
  • This almost worked for me, I just had to add --brightness 0.7 to the output where I set crtc 1. Oct 14, 2019 at 7:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .