1

Canon MG5370 printer&scanner is connected to the same network as Ubuntu 20.04. Using Settings --> Printers --> Add, Ubuntu 20.04 is able to detect this printer. However, when I try to "Test Print", nothing happens.

I believe this happens because it is using a generic printer driver. See picture below.

printer issue

On a Ubuntu 18.04 system in the same network, this same printer works and I can see it is using the driver called Canon MG5300 series - CUPS+Gutenprint v5.2.13.

To install this driver, I clicked the Gear button and selected Printer Details. There after, I clicked Search for Drivers. However, it can't find a suitable driver. Next, I clicked on Select from Database --> Canon but could not find any MG or MG5300 drivers.

I have also tried this solution. Installation was successful but it could not find the scanner not even when the printer-scanner is connected to the system via usb. See below.

scangear error msg

Previously, I had enquired about setting up this same printer's scanner for Ubuntu 16.04. I tried the solution there. Installation of Canon's scangermp failed too due to .

$ sudo ./install.sh
==================================================

ScanGear MP
Version 1.80
Copyright CANON INC. 2007-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/scangearmp-common_1.80-1_amd64.deb
Selecting previously unselected package scangearmp-common.
(Reading database ... 256647 files and directories currently installed.)
Preparing to unpack .../scangearmp-common_1.80-1_amd64.deb ...
Unpacking scangearmp-common (1.80-1) ...
dpkg: dependency problems prevent configuration of scangearmp-common:
 scangearmp-common depends on libpng12-0 (>= 1.2.8rel); however:
  Package libpng12-0 is not installed.
 scangearmp-common depends on libusb-0.1-4 (>= 2:0.1.10a); however:
  Package libusb-0.1-4 is not installed.

dpkg: error processing package scangearmp-common (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 scangearmp-common
Command executed = sudo dpkg -P scangearmp-common
(Reading database ... 256695 files and directories currently installed.)
Removing scangearmp-common (1.80-1) ...
Purging configuration files for scangearmp-common (1.80-1) ...

What should I do to setup this Canon MG5370 printer-scanner in Ubuntu 20.04? I want to be able to print and scan.

Update:

$ driverless
$ driverless list
DEBUG: Started ippfind (PID 25370)
DEBUG: Started post-processing (PID 25371)
DEBUG: PID 25370 (ippfind) stopped with status 1!
DEBUG: PID 25371 (Post-processing) exited with no errors.

$ lpinfo -v
file cups-brf:/
network beh
network http
network ipp
network lpd
serial serial:/dev/ttyS0?baud=115200
network https
network ipps
direct hp
network socket
direct usb://Canon/MG5300%20series?serial=20EE62&interface=1
direct hpfax
network dnssd://Canon%20MG5300%20series._printer._tcp.local/?uuid=urn:uuid:00000000-0000-1000-8000-8887178XXXXX

Outcome from following @brian_p answer:

$ scanimage -L
device `pixma:04A91754_20EE62' is a CANON Canon PIXMA MG5300 multi-function peripheral
device `airscan:w1:Canon MG5300 series' is a WSD Canon MG5300 series ip=192.168.1.XXX
$ airscan-disciver
airscan-disciver: command not found
$ airscan-discover
[devices]
$

Results For printing:

sudo apt install printer-driver-gutenprint was successfully completed.

$ lpinfo -m | grep MG5370
gutenprint.5.3://bjc-PIXMA-MG5370/expert Canon PIXMA MG5370 - CUPS+Gutenprint v5.3.3
$ lpadmin -p MG5370 -v dnssd://Canon%20MG5300%20series._printer._tcp.local/?uuid=urn:uuid:00000000-0000-1000-8000-8887178XXXXX -E -m gutenprint.5.3://bjc-PIXMA-MG5370/expert
lpadmin: Printer drivers are deprecated and will stop working in a future version of CUPS.
$ lp -d MG5370 /etc/nsswitch.conf
request id is MG5370-2 (1 file(s))

Wireless printing was successful.

7
  • Please give what you get from driverless.
    – brian_p
    Sep 1, 2021 at 13:10
  • @brian_p What is driverless? Thanks for the info in your answer. I will try that and report back.
    – Sun Bear
    Sep 1, 2021 at 13:53
  • It is a command that provides a URI for your printer. Execute man driverless for details. A URI is where a printer job is sent to. It is essential information to know.
    – brian_p
    Sep 1, 2021 at 14:31
  • @brian_p I have updated the result from driveless to my question.
    – Sun Bear
    Sep 1, 2021 at 17:15
  • Without an output from driverless` I cannot continue my direction to a driverless printing solution. There is another way. Give lpinfo -v. Can we get the info to progess with scanning?
    – brian_p
    Sep 1, 2021 at 18:00

1 Answer 1

1

I will tackle scanning first. Printing later. The assumption is that the device is connected to the network.

On Ubuntu 21.04 a user would be given sane-airscan by default. You will have to go here and then move on to download a Debian package from here. Install the package and execute scanimage -L and airscan-discover. Post the outputs back to us.

  • The MG5730 is an oldish printer in technical terms. However, it is likely to understand the WSD protocol
  • For scanning on USB I would normally recommend ipp-usb, but I do not think it will work with this device.

For printing the network URI is

dnssd://Canon%20MG5300%20series._printer._tcp.local/?uuid=urn:uuid:00000000-0000-1000-8000-8887178XXXXX

and the USB URI is

usb://Canon/MG5300%20series?serial=20EE62&interface=1

Now install printer-driver-gutenprint and do lpinfo -m | grep MG5730. The PPD begins gutenprint and ends with expert.

Execute lpadmin -p PRINTER_NAME -v URI -E -m PPD, substituting what you have for URI and PPD. PRINTER_NAME can be what you want, for example, 5730. Test printing with lp -d PRINTER_NAME /etc/nsswitch.conf.

6
  • I have uploaded the outcome in my question.
    – Sun Bear
    Sep 1, 2021 at 18:02
  • I confirm that Document Scanner, which is very similar to Simple Scan, can now scan via wifi. It is WSD flavour. This is great news. However, when I tried to use the same scanner connected via usb, although DS can detected the scanner, the scanned document appears entirely black in colour. I can't print to printer yet via wifi or via usb.
    – Sun Bear
    Sep 1, 2021 at 19:34
  • You wrote, "Now install printer-driver-gutenprint". Do you mean I do sudo apt install printer-driver-gutenprint?
    – Sun Bear
    Sep 2, 2021 at 11:05
  • sudo apt install printer-driver-gutenprint is fine.
    – brian_p
    Sep 2, 2021 at 11:12
  • Printing via wifi is successful. Thank you very much for your guidance. There is a typo in your answer. It should be lpinfo -m | grep MG5370.
    – Sun Bear
    Sep 2, 2021 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.