2

I've got a brand new ThinkPad X1 Carbon Gen. 9 with no pre-installed OS. After checking that Secure Boot is Off and OS Optimized Defaults are Disabled, I installed Ubuntu 20.04.3 LTS. If I try to shutdown the device, it shows a black screen but does not turn off. The only indicator is that the fans keep spinning. Even the power LED is Off. I waited up to one hour and did a force-shutdown several times by pressing the button for 10s. The problem persists on the next shutdown. All updates are installed.

When I first installed it, I set up LVM and encryption during the installation. This resulted in error messages during shutdown:

systemd-shutdown[1]: Could not detach DM /dev/dm-0: Device or resource busy
systemd-shutdown[1]: Failed to finalize DM devices, ignoring

After this, I did a fresh install without LVM and encryption. I don't get the messages anymore, but I still get stuck on the black screen.

I saw several posts about shutdown issues with 20.04, but I couldn't find any solution. Is this device specific? Should I return it and get the same device with the OEM image pre-installed? This would be a complete waste of resources just because Lenovo is not handing out their OEM image and I still don't know if the shutdown is working properly. From my experiences, Ubuntu certifications do not mean a lot in the Lenovo world. The support on the phone keeps telling me I should install Windows. I'm not expecting too much help from their side.

7
  • If the power LED is off, there is no OS running. If the fan is still running that can mean one of two things: (1) the battery is too hot while charging (2) the CPU is too hot despite being off. The fans on the Carbon models are mostly controlled through the UEFI, not the OS.
    – matigo
    Aug 31 at 10:08
  • I should mention that they're running just very silently. Furthermore, the power button does not work again to turn it on before I do a hard reset. I think this shows that neither (1) nor (2) is the problem in this case.
    – pixelpress
    Aug 31 at 11:34
  • If the firmware is fully up to date, then you may have a bum Carbon. There are several hundred of these deployed across the organization I work with, all running 20.04 or 21.04 and I’ve yet to hear of this issue. One way to test whether it’s the OS or not would be to boot into a Live USB session and shut down from there. If the issue repeats itself, then there’s a high probability it’s hardware related 😕
    – matigo
    Aug 31 at 12:28
  • And you're also running Ubuntu on Gen. 9 in your organization? I'm going to do a BIOS reset, reinstall and also trying the live session now.
    – pixelpress
    Aug 31 at 13:44
  • Live USB shutdown seems to work. However, I'm not sure if the procedure is the same, since the Live version asks to remove the USB device before turning off. Also, sometimes shutdown seems to work with the installation (1 of 5 cases).
    – pixelpress
    Aug 31 at 14:37
2

You need to activate additional drivers and update the firmware.

First run these commands:

fwupdmgr refresh --force
fwupdmgr get-updates
fwupdmgr update

After this your PC will probably restart. Make sure that it's connected to the power supply.

After that, you need to activate additional drivers and reboot again (check photo):

Ubuntu 20.04 Additional drivers

0

I got the Ubuntu 20.04 LTS OEM image from Lenovo and the issue was solved even after updating!

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.