I recently bought a Radeon HD 6850 and installed a fresh version of 12.04 on my computer.

It has 4GB RAM, a somewhat fast CPU and a suprisingly fast S-ATA HDD.

However I noticed that my 3D performance is extremely low, which causes the whole system to be slow.

As mentioned in this question, glgears has an average FPS of 70 and fgl_glxgears an average of 45.

I am using Unity 2D and have the supported driver from "Additional Drivers" installed. (not the post-release one).

fglrxinfo Output:

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series 
OpenGL version string: 4.2.11627 Compatibility Profile Context

glxinfo | grep rendering: direct rendering: Yes

xvinfo Output

I noticed this problem already when installing, so I tried the current release from AMD's website and an older one (11.X) - both didn't work as intended, as they had some weird glitches sometimes.

After that I reinstalled Ubuntu, so there is nothing from that that could interfere.

Does anyone of you have an idea what is going on?

/edit: unity_support_test Output:

OpenGL vendor string:   ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series 
OpenGL version string:  4.2.11627 Compatibility Profile Context

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
  • Run this command, and report its output. dpkg -l fglrx* | grep ^ii | awk ' { print $2 }' – J. M. Becker May 12 '12 at 20:00
  • This will tell us which FGLRX package you have installed, so we might know if choosing the other is preferred. – J. M. Becker May 12 '12 at 20:37
  • I also want to know, have you ever used this card in another OS. Such as any version of MS Windows, or other version of GNU/Linux... Possibly an older version of Ubuntu? If so, did you get good performance? I don't really believe something is wrong with your card, but with reporting a correct configuration... and yet getting such low FPS scores... It makes me consider the possibility. – J. M. Becker May 12 '12 at 20:40
  • fglrx and fglrx-amdcccle. Yes, the card works fine on Windows7, just tried it with Alien Swarm. I haven't tried an older Ubuntu version yet, but I will download a 11.04 live cd and have a look. – Force May 12 '12 at 20:53
  • @Focre, NO don't go with an old distro at this point. there may be no need to do that. I just wanted to see that your card worked as expected, sometime in the past. You have convinced me of that, so now read my answer.. follow its instructions. – J. M. Becker May 12 '12 at 21:37

The first thing I would do is install the newer versions of FGLRX, as you have the version available at distro release. you do not need to get a version from AMD, at this point, you can get the updates version from the repository.

First uninstall your current version.

sudo apt-get purge fglrx fglrx-amdcccle

Then install the newest version, available in the repository

sudo apt-get install fglrx-updates fglrx-amdcccle-updates

Restart your computer, Log back in your desktop, report your FPS results again.

I also want to mention, You will get very low framerates if you have "Wait for vertical refresh" set to any of the "ON" options. Make sure it is set to "Off, unless application specifies" You can find it in the Catalyst Control Center. That is the only other reason, which I could think of, that would cause such low FPS on a correct configuration. I'm 100% serious, you need to check on this setting. This is not a mere suggestion, it is that significant to the FPS scores.

  • Nope, no difference. glxgears ~ 100 FPS and gfl_gxgears ~35 FPS. – Force May 12 '12 at 23:01
  • And as I said before, that's a new card, so I haven't tried it with an older Ubuntu version yet. I might just try it with a live cd on a usb key tomorrow... – Force May 12 '12 at 23:02
  • this worked for me. I've got a system from ~2010 with a Radeon 5850. Even with the December 2013 stable drivers installed from the ATI website, I was getting ~60fps with fgl_glxgears. Using apt-get to install from the repos, I'm looking at 700-800 fps, and 800-1000 with glxgears. Much better, thanks! – ether_joe Mar 22 '14 at 23:06

My Solution was:

  1. sudo apt-get purge fglrx fglrx-amdcccle
  2. sudo apt-get install fglrx-updates fglrx-amdcccle-updates
  3. start Ati Catalyst Control Center -> confirm monitor frequence and resolution to be set to optimum/recommended (for my both devices - Monitor/TV - the setting was wrong -> this got me the most performance boost)
  4. Enable "Tear Free Desktop to enabled tearing" in the display options tab
  5. In the advanced settings of EACH pluged device (Monitor, TV) there was a tab were I could activate one of two checkboxes. One checkbox says something like "let graphics adapter do..." then another great performance boost was to realize!
  • With the Tear Free Desktop setting,GLGears actually stopped working, even after a reboot. I haven't found the option you mentioned in point five. – Force May 16 '12 at 16:51
  • Also the enabling "Tear Free Desktop" decreased the performance significantly. – Force May 18 '12 at 17:42
  • 2
    @Andreas Mühlberg: I actually would expect both those settings would decrease performance, under usual conditions. Tear Free Desktop is a quality related configuration, and the default OFF is the better performance. As for the scaling, you would only want your adapter to handle scaling if you have a compelling reason. I say compelling because it theoretically lowers performance, as you move yet another task on your card.. which was previously handled by the display. You get the traditional acceleration when tasks would otherwise be handled by the CPU. – J. M. Becker May 19 '12 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.