I am currently using ubuntu 12.04 I have acer aspire timelinex 3830tg with 2GB nvidia GeForce GT540M graphics card

To enable my graphics card I followed following steps.

1.) I activated nvidia_current and nvidia_current_updates from additional drivers

2.) sudo nvidia-xconfig

3.) then reboot

Following these steps I got following errors

1.) my resolution is 640x480...(there is no option of 1366x768 in display...previously there was 1366x768 when nvidia-xconfig command was not entered)

2.) when I open nvidia-settings it shows me following error "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root) and restart the X server."

Problem need to be solved

1.) Change resolution to 1366x768

2.) Also how to check my nvidia graphics working or not

Please some one please help me to solve these issues...I am seriously in need of my graphics card... I wan't my nvidia graphics card work as my intel graphics smoothly I am not willing to use bumblebee

with regards,

ubuntu user


I had this same problem just now after I installed some updates, exactly the same as described, except that it worked fine prior to the update.

I got around the issue by opening 'Additional Drivers' and reactivating my driver, as it had been deactivated for some reason.

After a quick reboot it was working fine, although I did have to manually select the resolution (the correct option was there this time), as it didn't do so automatically.

Looking at the age of this post I would think the problem is already solved, but hopefully this will be of help to anybody else with the same problem.

| improve this answer | |

This should take you back from where you've started:

  • log into tty1
  • sudo service lightdm stop (to stop the X session)
  • cd /etc/X11/
  • replace the conf generated by NVIDIA with the old conf:

    sudo mv xorg.conf.nvidia-xconfig-original xorg.conf
  • sudo service lightm start (to restart X session)
| improve this answer | |

You should have read Is a NVIDIA GeForce with Optimus Technology supported by Ubuntu?. nvidia-xconfig is going to break your desktop. So you don't want to use Bumblebee to make use of your video card? Fine, but then you have to wait 1-2y for a final solution, PRIME (which is likely going to land in Linux 3.5) and an updated Xorg/Wayland + Mesa stack. (if you're "lucky", you can set your nvidia card as default in your BIOS. Disadvantage: high power consumption).

If you've just bought the machine, you could return it to the shop. Optimus is currently a disaster. See the linked question in the first sentence how to repair your installation.

| improve this answer | |
  • I am in need of nvidia is for only one reason ie for my virtual box...I am willing to have video memory option of 2GB in virtual but now it shows 128MB only...I had install bumblebee and used command "optirun virtualbox" but it showed video memory 128MB only...if its possible to give 2GB video memory for virtualbox using bumblebee please recommend me – Deepak Adhikari May 13 '12 at 4:42
  • Hmm, well the issue is that VBox needs hw access to the card. Try setting up Remote Desktop (or similar) on the VBox instance (possibly using the VBox control panel). Once that's done, close VBox and start it like optirun VBoxManage startvm "Your VM Name". Your VM Name is the name as shown in the overview window and can also be gathered from VBoxManage list vms. – Lekensteyn May 13 '12 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.