0

I'm using Thunderbird 68.10.0 on Ubuntu 18.04. I had xul-ext-lightning installed (version 68.10.0). My local calendar was working fine. Today, xul-ext-lightning was upgraded to 78.11.0 (TB was left untouched as I have apt-mark'ed it), and I couldn't open any calendar items any longer. After restarting TB, my calendar is gone, no "Events and Tasks" menu, no calendar icon on the top right...

I tried all steps on this link, but they don't apply since the plugin is installed as per above.

There's also no error message from TB in regards to the plugin.

What else can I try? Do the versions of TB and xul-ext-lightning have to be the same? If so, how can I downgrade the plugin back? I tried apt-get install xul-ext-lightning=1:68.10.0+build1-0ubuntu0.18.04.1 (which was the previous version as per /var/log/apt/history.log) but it came back with E: Version '1:68.10.0+build1-0ubuntu0.18.04.1' for 'xul-ext-lightning' was not found.

Thanks.

1 Answer 1

0

This is indeed an error from the part of the Ubuntu developpers, where they apparently upgraded the plugin without upgrading the main Thunderbird package. It can be expected that the main Thunderbird package will be upgraded soon as well, but in the mean time this leaves you without a productivity tool that could be essential for your daily work.

You can revert to an earlier version of a package. Once you installed the earlier package, you should "hold" it to prevent it from automatic updates. If ever Thunderbird is upgraded on you 18.04 (unlikely), you can remove the package xul-ext-lightning, because the calendar is now part of the main program in Thunderbird 78.

1
  • This. I've downgraded the xul-ext-lightning packages and marked them to be held. However, to downgrade, I needed to download the dep files, the earlier versions were gone from the Bionic repos. Commented Aug 27, 2021 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .