Title. I've done a bit of searching here but I'm quite baffled. I recently acquired a Samsung Galaxy S7, and while I'm quite excited about it, I'm having difficulty transferring files via USB. "The name 1.110 was not provided by any .service files" is the error message I'm getting when clicking on the phone's icon in nautilus (the stock version with Ubuntu 20.04, btw)

I've tried enabling every feature that seemed relevant, such as USB tethering, phone visibility, and so on, and have had no luck.

I've also tried enabling an FTP server on my phone, and connecting to it but the connection is timing out, though I'm not sure if that was due to an error on my part (I tried enabling and disabling anonymous logins, and enabling and disabling the password requirement), and while I didn't try restarting my router out of desperation (yet) I feel that wouldn't help in this instance, and I couldn't find any useful information on this front as I was directed to an SCP server (which upon googling led me to guides on an SSH server...And to be honest, it sounds quite intimidating), but if it's the easiest way, I'm happy to put in the work if anyone has any suggested reading or watching.

For reference, I was able to transfer files to and fro my much older Zenfone, without any issue, so I believe the issue is with some sort of android file transfer protocol update, rather than any issues with my ubuntu configuration, though I could be wrong.

I'm not dead set on any particular solution, I just want a simple way to transfer files. If it helps, both my PC and phone are on the same connection, and if need be I'm willing to buy a wifi, or bluetooth USB adapter for my computer if it will simplify things.

I'm sorry if this is a frequently asked question but I honestly just can't seem to phrase what I'm asking search engines correctly to get a useful answer, and I'd like to thank in advance any coming answers.


1 Answer 1

  1. Download the Android SDK Platform Tools ZIP file for Linux.
  2. Extract the ZIP to an easily-accessible location (like the Desktop for example).
  3. Open a Terminal window.
  4. Enter the following command: cd /path/to/extracted/folder/
  5. This will change the directory to where you extracted the ADB files.
  6. So for example: cd /Users/Doug/Desktop/platform-tools/
  7. Connect your device to your Linux machine with your USB cable. Change the connection mode to “file transfer (MTP)” mode. This is not always necessary for every device, but it’s recommended so you don’t run into any issues.
  8. Once the Terminal is in the same folder your ADB tools are in, you can execute the following command to launch the ADB daemon: ./adb devices
  9. Back on your smartphone or tablet device, you’ll see a prompt asking you to allow USB debugging. Go ahead and grant it. Alllow usb debugging
  10. Finally, re-enter the command from step #8. If everything was successful, you should now see your device’s serial number in the Terminal window output.adb devices

Source: https://www.xda-developers.com/install-adb-windows-macos-linux/

Use adb push command to transfer file: adb push <path_to_the_local_object> <path_to_the_remote_destination>


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .