1

Installed Windows 10 first, then Ubuntu 20.04 on top, in dual-boot. Worked very well for a few months, suddenly the Windows boot option returned this:

"error: file '/EFI/Microsoft/Boot/bootmgfw.efi' not found"

I ran bootinfoscript, and got this first RESULTS.txt: https://u.pcloud.link/publink/show?code=XZXMYlXZGVTc4SlE7LR0sfdKoPUuORUcRubV

I checked this folder in the EFI System Partition (sdb1), and sure enough there was no "bootmgfw.efi" file there. I got this file from the Windows partition (/Windows/Boot) and tried to copy to the place the grub was looking for, but this is what I got:

root@i3-4170-ubuntu:/mnt/EFI/Microsoft/Boot# cp -f /home/wolf/bootmgfw.efi /mnt/EFI/Microsoft/Boot/.

cp: cannot create regular file '/mnt/EFI/Microsoft/Boot/./bootmgfw.efi': Read-only file system

Following instructions from a forum post, I went with sudo update-grub and the result was:

Sourcing file `/etc/default/grub'

Sourcing file `/etc/default/grub.d/init-select.cfg'

Generating grub configuration file ...

Found linux image: /boot/vmlinuz-5.11.0-27-generic

Found initrd image: /boot/initrd.img-5.11.0-27-generic

Found linux image: /boot/vmlinuz-5.11.0-25-generic

Found initrd image: /boot/initrd.img-5.11.0-25-generic

find: ‘/boot/efi/EFI/Microsoft/Boot/es-ES’: Input/output error

Adding boot menu entry for UEFI Firmware Settings

done

I restarted and, this time, the Windows boot option did not appear at all. In fact, the computer booted directly into Ubuntu 20.04, skipping the menu entirely.

I tried boot-repair, which was also suggested in a forum. It failed to repair the GRUB, stating that it found a LegacyWindows partition and that a compatibility mode had to be se in the UEFI firmware. I highly doubt it, since I very consciouly installed Windows 10 and Ubuntu on UEFI mode, with Legacy disabled. Plus, it was never a problem for the last few months.

I ran bootinfoscript after this, and got this second log, renamed RESULTS-2.txt: https://u.pcloud.link/publink/show?code=XZMxYlXZHrECQn04trJYv3eYKdrNYRIwXuCk

This line from update-grub above caught my attention: find: ‘/boot/efi/EFI/Microsoft/Boot/es-ES’: Input/output error. But I will not mess with it further until I get some help, if anyone could be so kind.

7
  • Before anything else please check UEFI > Boot. Can you select "Windows bootloader manager" in order to boot Windows directly? Aug 25, 2021 at 18:40
  • Thank you! It was one of the first things I tried, and tried again now, with no effect. "Windows bootloader" appears as an option in UEFI boot menu, but it doesn't boot.
    – Lenk
    Aug 25, 2021 at 18:56
  • You need to boot a Windows 10 installation USB and repair it. Grub can only boot working Windows. If it doesn't boot directly then it isn't a Grub's or Ubuntu's problem. Aug 25, 2021 at 18:58
  • Did it! Worked! Now I can boot both Ubuntu and Windows from UEFI boot menu. Do I try to repair the Grub now? how? Thanks a lot!
    – Lenk
    Aug 25, 2021 at 19:05
  • 1
    Please consider posting an answer with the details of your solution. Our primary goal on Ask Ubuntu is to provide a library of questions and answers about Ubuntu.
    – Nmath
    Aug 25, 2021 at 20:08

1 Answer 1

0

Solved:

-Tried booting into the Windows partition directly from the UEFI Boot Menu. It didn't work.

-Booted into a Windows 10 installation USB pendrive, then "Repair", then "Repair Windows initialization" or something like that. It automatically found the windows partition and repaired it.

-With that, I was able to boot into Windows from the UEFI. I just needed to repair the GRUB, which I did booting into Ubuntu and running sudo update-grub

Thanks @ChanganAuto for the help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .