9

I am new to Ubuntu and want to install VMWare Player. What is the step by step procedure to install that?

  • 2
    This question is notably different than its possible duplicate by what the question is asking. I have reopened it. – Thomas Ward Oct 31 '19 at 15:41
  • 1
    And I edited to remove the Duplicate banner :P – Kulfy Oct 31 '19 at 16:07
20
+200

Since VMware Player is not provided by the repositories, you have to instead download it here at the VMware website.

Note that VMware Player (like VMware Workstation) no longer has a 32-bit version, so if running uname -m shows x86_64, you can run it, but if it shows i686, you can't (or would have to use an old version).

After the download completes, go to the folder to which you downloaded it in the Terminal. You can do this with the cd command. For example, if you put it in your Downloads folder, run:

cd ~/Downloads

(In the Terminal, the ~ character at the beginning of a file path represents your home folder.)

Now make this installer file executable with the chmod command. Currently, VMware Workstation 15.1.0 Player Build 13591040 is the latest version. For that, you would run:

chmod +x VMware-Player-15.5.0-14665864.x86_64.bundle

Use the full name of whatever file you download. The naming convention might change in the future, but even if it does not, the filename contains version numbers, so each version of VMware Player has a different filename. (Tab completion is handy for this: if you type the first few characters of the filename and press Tab, your shell should expand it automatically to the whole filename if it's the only file in the current directory that starts that way.)

The installer may need to build and install kernel modules, so it's advisable to make sure you have the necessary packages to facilitate this. Run uname -r. These days, the output usually ends in -generic. On old versions of Ubuntu, generic-pae, server, and virtual were common too. If it doesn't end in -generic, replace -generic below with whatever it does end in.

sudo apt-get update
sudo apt-get install build-essential linux-headers-generic

Now run the installer. You have to run it as root, so use sudo:

sudo ./VMware-Player-15.5.0-14665864.x86_64.bundle

(As before, you should use the name of the file you downloaded, and tab completion can help. Note that ./ immediately before the filename is important in this command.)

The rest of the installation process is guided and graphical. While you had to run the installer as root with sudo, you do not generally need to run, and should not generally run, VMware Player as root after you've installed it. Occasionally, after an update to your kernel or VMware Player, VMware Player may ask you to allow it to build and install new kernel modules as root. That's okay.


With old versions of VMWare, you may get a kernel error when running it for the first time. If possible, you should use a newer version--or at least a version that is still supported--not just to solve those problems, but also because hypervisors like VMware Player and VMware Workstation can contain security vulnerabilities that get patched in supported versions. However, if you do use an old version and get kernel errors, see this page. If you believe you have the problem described there, you can download and run patch-modules.sh.

cd /tmp
wget http://communities.vmware.com/servlet/JiveServlet/download/1553530-39784/patch-modules.sh
wget http://communities.vmware.com/servlet/JiveServlet/download/1553530-39785/vmware-7.1-2.6.35-3-generic.patch
sudo sh patch-modules.sh

If that doesn't work (and it asks you for the patch location) try this for the location:

/tmp/patch-modules.sh

This extra information was taken from that page, and all I did was add the /tmp/patch-modules.sh. You should refer to the forum link above if you're going to attempt this (or have trouble with it). Most users today will not need to do that.

|improve this answer|||||
  • Thanks, I can install the VMWare, but after I run some modules updater under kernel, it prompted me an error "unable to start services, see logfile.... – willy May 15 '12 at 21:42
  • I got patch module update 3.2.0.sh , I can run my VMPlayer now, thanks :) – willy May 15 '12 at 22:03
  • Can you share the link to the patch ? – Yugal Jindle May 18 '12 at 9:52
  • @willy Can you tell us how you got the patch? I'd like to add that to my answer. – Eliah Kagan May 18 '12 at 15:16
  • 1
    It's no longer required you to register/login to get the installation file from their download page – Adonis K. Kakoulidis Aug 28 '12 at 18:48
13

http://downloads.vmware.com/d/info/desktop_end_user_computing/vmware_player/4_0

Click on download Then Register IT enter image description here Complete Registration enter image description here Then Download The Version You Want To I Have Ubuntu 11.10 x64 bit enter image description here Download enter image description here Once Downloaded then run the Following Command

  sudo apt-get install build-essential linux-headers-`uname -r`

then go to your Download Directory

cd Download   (full command will be cd /home/your-user-name/Download)
ls -l
gksudo bash ./VMware-Player-4.0.2-591240.x86_64.bundle

enter image description here enter image description here enter image description here enter image description here

enter image description here

Help Taken

http://www.howtoforge.com/how-to-install-vmware-player-on-ubuntu-11.04-linux-mint-11

https://help.ubuntu.com/community/VMware/Player

|improve this answer|||||
  • pic no 5 6 7 8 will show you version 4 , as i have copy pasted , so dont worry abt it – One Zero Feb 3 '12 at 18:38
9

You can download the Vmware player for Linux from the official website with .bundle as the extension.

After that navigate to the downloaded folder in terminal.

Then use the command:

sudo sh filename.bundle 

it will do the remaining job.

It worked for me.

|improve this answer|||||
  • VMWare Player 5.0.1 is the current version and it worked just fine for me. I used the instructions from here: liberiangeek.net/2012/09/… – draganstankovic Nov 10 '12 at 14:50
  • The same is the case for Kali Linux. I've manually installed VMware on my Kali using the same technique, two weeks ago. – Jishan Shaikh Nov 1 '19 at 12:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.