I'd like to print a PDF with custom page margin settings.

So I opened the PDF with Evince (standard document viewer) and added a new page size in the print dialog:

It has a bigger margin on the right side in this case.

But on the printed paper or in the print preview the margins are ignored no matter what the exact settings are. When I do the same procedure in GIMP in the print dialog it works perfectly as expected but Evince just seems to ignore the margin settings. Unfortunately in GIMP I can't print all pages in a PDF at once so I'm looking for a solution with Evince or a better PDF viewer if there is one.

  • 1
    What is set on the Page Handling tab in Page Scaling? It should be set to Shrink or Fit to Printable Area, especially if the source document has different page size than the format used in your printer.
    – jnv
    May 12, 2012 at 17:16
  • 1
    Yes, I tried with both. Still margins are ignored.
    – P_M
    May 12, 2012 at 17:37
  • 2
    3 years later, still the same problem. Isn't this worthy a bug-report?
    – tlwhitec
    Oct 15, 2015 at 16:22
  • 1
    Is there still no solution to this? Jan 7, 2017 at 0:20
  • 3
    only today I have seen this annoying issue, so I have opened a bug: bugzilla.gnome.org/show_bug.cgi?id=780802
    – mattia.b89
    Apr 1, 2017 at 10:05

4 Answers 4


You can try Okular that can print all pages in a PDF like Evince.

  • 2
    Well, the same happend with Okular. I set a big border margin on one side and printed to a PDF and it ignores it too.
    – P_M
    May 12, 2012 at 17:50

I also faced the problem with the ignoring of larger borders, which I set, when printing a PDF document via evince. I was successful to solve the problem by using the ghostview and printer installed directly to my PC. (Unfortunately, the ghostview was not working properly when I tried a printing on a remote printer connected with the PC via web.)

  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) Mar 8, 2017 at 10:06

Bumped into the same problem. I was trying to print a cropped pdf as two pages on one slide. I'm glad I found this post because I thought I was doing something wrong.

My work-around: use the pdf viewer in Firefox. Most Ubuntu users have this web browser, so this is perhaps the easiest work-around.

Still, it's an Evince nuisance, hence +1 for mattia.b89


I have an idea for a workaround:

Open a PDF with the Firefox browser -> Click on the small printer symbol in the top right -> Click "More Settings" -> If I set Scale to 50 the PDF can be printed with a white border.

Maybe somebody else knows how to define a paper format for the Firefox PDF printing function to customize the borders/margins. enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .