1

Recently, I attached an aluminium USB Apple keyboard to my Thinkpad running Ubuntu 20.04, setting Compose to Caps using dpkg-reconfigure keyboard-configuration.

Now I cannot get my old Left Win / Super keys behaviour back.

I'm manually setting the keyboard layout using setxkbmap -option "" -variant "" -layout "de" -model "pc105" multiple times a day (probably every time the laptop suspended) and I'm out of ideas where else the system could get the undesired setting.

This is the config

/etc/default/keyboard (that's what I want!):

XKBLAYOUT="de"
BACKSPACE="guess"
XKBVARIANT=""
XKBMODEL="pc105"
XKBOPTIONS=""

setxkbmap -query: completely puzzled about this. Keyboard behaves like a pc105 alright, not sure where the variant: ,mac,, comes from and most importantly: lwin shouldn't be Compose.

rules:      evdev
model:      pc105
layout:     de,de,gb,gb
variant:    ,mac,,
options:    compose:lwin,terminate:ctrl_alt_bksp

The Ubuntu keyboard layout view agrees with the settings returned by setxkbmap -query: Keyboard layout showing lwin as Compose

Gnome Tweaks says the Compose key is Disabled:

Gnome Tweak screenshot

I do not have an /etc/X11/xorg.conf.

Pointers on where to look for persisted settings much appreciated. Thanks!

2
  • 1
    Perhaps something set in Gnome: what does gsettings get org.gnome.desktop.input-sources xkb-options say? You cannot "reset" running dpkg-reconfigure again (you didn´t mention any attempt in that direction).
    – vanadium
    Aug 23, 2021 at 7:15
  • @vanadium gsettings get org.gnome.desktop.input-sources xkb-options returns "['compose:lwin', 'terminate:ctrl_alt_bksp']", in line with what the Gnome keyboard layout widget shows. I am able to (temporarily) change my keyboard layout back using dpkg-reconfigure, but that a) takes a long time and b) doesn't last.
    – carp
    Aug 24, 2021 at 6:57

1 Answer 1

0

After having been pointed to gsettings get org.gnome.desktop.input-source xkb-options in Compose key keeps coming back. How to disable it permanently?, I was able to gsettings set:

gsettings set org.gnome.desktop.input-sources xkb-options "[]"

So far, the settings stick and I am able to reliably use the Gnome keyboard layout switcher to change between keyboard layouts.

keyboard switcher tray

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.