I have installed Ubuntu 12.04 on my laptop.Every thing is working fine.But from last two days I am facing a problem and that is when I am going to shutdown my system,it is showing the shutdown process but it is actually not doing shut down.The screen is reaming like that for many time then I am doing the forcibly shutdown by pressing the start key of my system.Can someone tell me what is the wrong going on?Any help and suggestions will be highly appreciable.


When the shutdown process was going on I just pressed the esc key and it showed the error message like this

modem manager[878]:<info>Caught signal 15,is shutting down...        [Fail]
  • 1
    This is a bug, so it needs to be reported on Launchpad as well. That way it'll get fixed quicker. – RobinJ May 12 '12 at 12:37
  • so how to report that? – newuser May 12 '12 at 13:00
  • I don't know whether it is a bug or not as described in RobinJ's comment above, but it is NOT recommend that turn off your Linux system by pressing the power button, in that rude case, you may get your file system broken. (Try fsck command to repair file system of ubuntu) In addition, you can try sync ;` sudo shutdown -h now` command in terminal, press F7 to see logs while shutdown progress to track what's happening. – vicd May 12 '12 at 13:14
  • bugs.launchpad.net/ubuntu – Hilmi Erdem KEREN May 12 '12 at 13:14
  • @erdemkeren Didn't EXT3 and EXT4 have a bunch of systems to prevent data corruption when the system was forcefully shut down? I don't deny it's not recommended, but that more for fear of hardware failure. – RobinJ May 21 '12 at 15:40

The problem is in NVIDIA driver. You have to go to System Settings --> Additional drivers and there you have to mark and install NVIDIA accelerated graphics driver (post-release updates (version current updates).

The Recommended driver above it causes the problem.

  • I don't have graphics card installed in my system. – newuser May 13 '12 at 9:48
  • 1
    How do you know he is using nVidia Drivers in the first place. – Starx May 16 '12 at 7:26
  • It looks like there is a bug for that: bugs.launchpad.net/bugs/991977 . If you are affected, click on "yes, it affects me too" at the top of the page. This will be counted. You can log on to Launchpad with your UbuntuOne ID. – Andre May 19 '12 at 17:25

I do not think it is related to the graphic card, I have an intel chipset and same annoying bug! For now I installed terminal emulator "Terminator" and created a launcher with the following command in it:

terminator -e "sudo shutdown -h now"

, it works everytime and will help me wait for the right update!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.