0

My laptop has an AMD Hainan Dedicated GPU and Intel Integrated Graphics 520. I installed Epic Games Launcher from the install script provided on the Lutris' website. I ran Lutris with DRI_PRIME=1 and then, ran Epic Store Launcher. I monitored my dGPU usage through radeontop. My laptop is perfectly using my dGPU when running Epic Games launcher, but switching back to Intel Integrated Graphics when running GTA V through it. Please suggest me how to run GTA V from Epic Store on my dedicated AMD GPU.

5
  • Kubuntu 20.04 LTS
    – Mumuzab
    Aug 22, 2021 at 13:50
  • If you can disable the iGPU that would be a an assured solution. Other than that you need to find a way to prime select the actual game directly instead of the store. Lutris is NOT Steam. Aug 22, 2021 at 16:05
  • I don't think I will be able to disable iGPU as my laptop display is directly connected to it and dGPU rendered frames has to pass through it to reach my display. I also made 'DRI_PRIME=1' as global environment parameter in my OS to render every possible thing through my dGPU. But still facing the same problem.
    – Mumuzab
    Aug 25, 2021 at 0:42
  • No, it works on both or just the dGPU, I never seen a hybrid graphics laptop requiring the iGPU for external connections. The reason being if you're using a monitor then you're near an electric outlet so the reduced battery life due to using the dGPU is moot. Aug 25, 2021 at 1:05
  • Are you talking about an external monitor connected to my laptop? I was talking about my laptop display. I do not use an external monitor. If you are talking about my laptop display, then please tell me how to diable iGPU completely. I made 'DRI_PRIME=1' as global environment parameter. Still, my problem persisted.
    – Mumuzab
    Aug 25, 2021 at 3:21

1 Answer 1

0

After searching on internet for solutions, I came to know that it is the problem of my radeon GPU driver. Apparently there is some issue of Vulkan support with this driver(Reference Article Here). My GPU is also supported by amdgpu driver. It was also present in my laptop, but my Linux distro selected radeon by default.

I followed this article and switched my driver from radeon to amdgpu and now, nearly everything runs on my dedicated GPU. The problem with my Epic Store games is now solved and few Steam games, which were earlier not detecting my dGPU are now running on it. There are a few performance issues though. I am working on it.

Though I have little qualification to comment on this, but I recommend that the distros should be configured to select the latest drivers for the hardware wherever possible. This could minimise the compatibility issues to a great extent. I have seen on the internet that many gamers are facing this driver issue(especially the ones which have slightly older hardware), which is an unnecessary hassle. Lesser issues will attaract more gamers to Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.