0

I'm running 21.04 server on Raspberry Pi CM3+ based device manufactured by Allo, their USBridge Signature.

On booting up the network card seems to be found but lshw reports it as disabled. Below is how it looks after I sudo dhclient enx0017f700a9d6 to enable network:1, which is what I want to happen by default.

My question is what do I need to do to ensure that the boot process enables the device? No doubt my question makes it clear I'm a Linux noob, so please pitch your reply to my level.

Thanks

*-network:0 DISABLED
description: Ethernet interface
physical id: 1
bus info: usb@1:1.2
logical name: enx0001f2fff397
serial: 00:01:f2:ff:f3:97
capabilities: ethernet physical
configuration: broadcast=yes driver=cdc_ether driverversion=5.11.0-1016-raspi firmware=CDC Ethernet Device link=no multicast=yes

*-network:1 description: Ethernet interface
physical id: 2
bus info: usb@1:1.3
logical name: enx0017f700a9d6
serial: 00:17:f7:00:a9:d6
size: 1Gbit/s
capacity: 1Gbit/s
capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=ax88179_178a driverversion=5.11.0-1016-raspi duplex=full ip=192.168.11.111 link=yes multicast=yes port=MII speed=1Gbit/s

Hi @chili555, Thanks for the response. Here's the results from cat /etc/netplan/*.yaml

This file is generated from information provided by the datasource. Changes
to it will not persist across an instance reboot. To disable cloud-init's
network configuration capabilities, write a file /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
network: {config: disabled}

network:
ethernets:
eth0:
dhcp4: true
optional: true
version: 2

3
  • I suspect that your netplan yaml file does not properly provide for enx0017f700a9d6 to start automagically. Let's have a look. Please edit your question to show the result of the terminal command: cat /etc/netplan/*.yaml Welcome to Ask Ubuntu.
    – chili555
    Aug 19, 2021 at 15:46
  • Perfect! Many thanks for your help @chili555. Don't understand it of course - as you say, simply automagical
    – johnanon
    Aug 20, 2021 at 15:56
  • Awesome! Glad it's working as expected.
    – chili555
    Aug 20, 2021 at 16:10

1 Answer 1

1

I assume this is not a cloud-init instance. If that is incorrect, please stop and tell us in the comments.

Let’s follow the instructions in the file. Please open a terminal and do:

sudo -i
echo “network: {config: disabled}”  >  /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg 
nano /etc/netplan/*.yaml

Replace the line eth0 with enx0017f700a9d6. Netplan is very specific about spacing, indentation, etc. so please proofread carefully twice.

Save (Ctrl+o followed by Enter) and exit (Ctrl+x followed by Enter) the text editor nano.

Follow with:

netplan generate
netplan apply
exit

You should be all set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.