19

How do I make Chromium on Kubuntu render Emoji Unicode characters ?

Like these : 💘💙💜💗💚❤💓💛💚💗

10

First, you need a font that contains those characters. According to support information at Fileformat.info, the only font that has them is Symbola, though it is possible that some less known fonts have them too. Symbola can be downloaded from http://www.fonts2u.com/search.html?q=symbola or http://users.teilar.gr/~g1951d/ (the latter is for the author’s site, hence preferable when it works).

Second, browsers have difficulties with special fonts. They are often unable to pick up special characters from various fonts. I’m afraid that if a page does not explicitly mention Symbola (as it really should in cases like this), the only thing you can do as a user is to make your browser use Symbola as the default font, at least temporarily (via the browser’s general settings).

1
  • Works without changing font in Chromium. But how did you found the corresponding code at fileformat.info ? – Cydonia7 May 13 '12 at 18:11
30

The Symbola font is part of the ttf-ancient-fonts package. You can install it by running this command in a terminal window:

sudo apt-get install ttf-ancient-fonts

Source

0
2

ttf-ancient-fonts gets you Black & White emoji.

For color emoji, it's only working with Firefox right now. The current best solution is to use eosrei/emojione-color-font or eosrei/twemoji-color-font via the Launchpad PPA:

sudo apt-add-repository ppa:eosrei/fonts
sudo apt-get update
# Choose one!
sudo apt-get install fonts-emojione-svginot # emoji one style
# Or
sudo apt-get install fonts-twemoji-svginot # twitter style

You're gonna need to restart your browser to see the change.

See also the Emojione Picker for Ubuntu

ad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.