1

Total newb here. Working on a fresh install of 20.04 on a MSI GS65 dual booting with windows.

I installed an app from a VPN provider and all worked fine until I rebooted... No DNS functions. I could ping/dig 8.8.8.8 but not www.yahoo.com. I purged VPN app.

syslog > systemd-resolved: Using degraded feature set for DNS server ::1.

/etc/resolv.conf

127.0.0.53

/etc/systemd/resolved.conf

dns=8.8.8.8

#everything else commented out in those two files

I can get dns working by editing resolv.conf but I know this is not correctly solving my problem. I'd really like to get this back to perfect being a new install. I can reinstall 20.04 but there is no advancement in my knowledge that route...

Things I have messed with without success: un-commented resolved.conf line DNS and added 8.8.8.8, tried to change network settings via gui. Some things we know; dig www.uu.net @9.9.9.9 works and dig www.uu.net @127.0.0.53 does not, systemd-resolve --status has current DNS 1.1.1.1

Any help or points to where I should be looking graciously accepted. And of course I'll provide any output that gets us closer to the source of issue. Thanks

1
  • Nothing you change in /etc/resolv.conf is going to stick. Read the commented lines. The first line says "Do not edit.". Have you researched the documentation from the developers of the app you had installed? Do they have instructions for uninstallation? If this software caused your problem, then you should disclose the name of the app, where you obtained it, details of how you installed it, and details of how you uninstalled it.
    – Nmath
    Commented Aug 16, 2021 at 22:17

1 Answer 1

0

I didn't get to the root cause of the problem and will continue studies on the DNS function. However, I did find an acceptable solution which was to reinstall the vpn software. This time around everything works as advertised.

Thank you for pointing my direction to the software Nmath!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .