1

I have Ubuntu 20.04.2 LTS and I'm trying to install drivers for my Linksys WUSB6300 Network adapter. I've tried two solutions so far and neither worked (How do I get the linksys WUSB6300 wireless adapter to work on linux and https://github.com/morrownr/88x2bu). I'm currently using ethernet but that's not a long term solution. The drivers work fine on Windows (the network adapter acts like a usb drive and has the drivers contained inside but they're only for windows). Are there any solutions or do I need to buy a new network adapter?

Edit: The "make" command in the first link returns an error (I'll try to get the error but I already closed the terminal window so I'm not sure if I can get it again exactly, had something to do with redefining something..), and the second one got me through the entire installation process but it didn't work, no WIFI options in the settings or any connection whatsoever. (The first link was for an older version of Ubuntu, if that helps. The only one that was tested on my version was the second github link which got through the process fine but there was no connection settings at all so I uninstalled the driver.)

lsusb:

Bus 002 Device 004: ID 1058:25e1 Western Digital Technologies, Inc. 
Bus 002 Device 003: ID 13b1:003f Linksys WUSB6300 802.11a/b/g/n/ac Wireless Adapter [Realtek RTL8812AU]
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 1038:161c SteelSeries ApS 
Bus 001 Device 003: ID 3938:1170  
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo dpkg -s usb-modeswitch | grep Status:

Status: install ok installed
2
  • 1
    Your question seems to be an exact duplicate of one of your links. The same question will result in the same answer. "neither worked" doesn't tell us anything useful that makes the question different. We might be able to help you...if you provide details of exactly what you did and show us the complete output. Alternately, buying a Linux-compatible dongle isn't a bad idea for some folks.
    – user535733
    Commented Aug 16, 2021 at 20:06
  • 1
    Please edit your questionn to show the result of two terminal commands: lsusb and also sudo dpkg -s usb-modeswitch | grep Status Welcome to Ask Ubuntu.
    – chili555
    Commented Aug 16, 2021 at 20:10

2 Answers 2

3

With a working internet connection, open a terminal and do:

sudo apt update
sudo apt install git dkms
git clone https://github.com/morrownr/8812au-20210629.git
cd 8812au-20210629
sudo ./install-driver.sh

Reboot. Your wireless should now be working.

2

If you have a WUSB6300 v2 wifi adapter, the 88x2bu drivers worked for me (Mint 20.3, 5.4.107 kernel, linksys wifi 13b1:0045). The 8812au drivers did not.

sudo apt update
sudo apt install git dkms
git clone https://github.com/morrownr/88x2bu-20210702.git
cd 88x2bu-20210702
sudo ./install-driver.sh

Nick is using a static landing page that will point to current version if this changes https://github.com/morrownr/88x2bu

1
  • Hello. If the OP would update their OS they may not need any of this. They are 20.04.2 and they should be on 20.04.4
    – David
    Commented Apr 10, 2022 at 8:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .