17

Running Ubuntu 21.04 on ThinkPad X1 Carbon 9th generation. When I suspend the computer, Slack closes down. Happens every time. Notified Slack, but wondering if anyone else here has encountered this.

UPDATE: See below. Going back to 20.04.3 fixed the issue, and Slack is working on it.

4
  • 2
    Everything was fine previously, but today Slack closes every time my screen times out. I'll make a coffee, come back and unlock the screen, and Slack is gone. No trouble reopening it. Slack snap version: slack 4.19.2 44 latest/stable slack✓ classic I don't think the hardware is the problem, based on others having the same issue, but... my machine is: Lenovo P14s Gen 2i (11th gen i7, 16GB), Ubuntu 21.04, Gnome 3.38.5, X11, hybrid graphics mode with nvidia driver 470. I've notified Slack, too, and linked this page.
    – David R
    Aug 25 at 2:06
  • Same issue for me, ThinkPad E480 and Ubuntu 20.10. The problem started when it updated to the latest version 4.19.2. Apart from the issues commented here, if I try to upload some file to a Slack channel or open an APP it closes suddenly
    – Averias
    Aug 26 at 9:03
  • 1
    I'm on 20.04.3, never upgraded to 21.04. Have the same issue Aug 30 at 7:45
  • 1
    If anyone's interested, Brendan Gregg investigated and found the source of the issue: brendangregg.com/blog/2021-08-27/…
    – Ory Band
    Sep 14 at 20:41
13

Try removing Slack cache directory after verifying slack is closed:

rm -r ~/snap/slack/common/.cache

So steps are:

  1. Close slack
  2. Delete cache folder via rm -rf ~/snap/slack/common/.cache
  3. Re-run slack, lock computer and verify it's still there
  4. think about it.. And miss the quite period when slack was shut down and you didn't notice, or - "didn't notice"
0
5

I went back to 20.04.3, which solved the problem.

Slack is aware of the issue and is working on it.

2
  • 3
    Or just delete ~/snap/slack/common/.cache, that fixed it for me. Found here: forum.snapcraft.io/t/… Sep 8 at 7:11
  • Strangely, the bug never occurs when Slack is launched directly by CLI, but only when launched by systemd (this happens when you click on the desktop shortcut)
    – JRo
    Sep 8 at 9:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.