1

I archived a lot of files and folders into a .img file... it is a disk image I made using dd and rsync. I then made an .iso file from the .img file (using ImgBurn in Windows 10).

Now I want to compare the contents of each to be sure the iso file contains all the same files that are in the .img file. For this I am using Meld in Ubuntu mate. When I double click on the .img file it mounts in the /media folder.

When I double click on the .iso file it opens in Engrampa Archive Manager and the mountpoint is /

Like this I am unable to browse to / via Caja file explorer when setting up the directory Compare in Meld. If instead I right click on the iso file and "Open-with" Disk-Image Mounter or Mate Disk-Image Mounter then it creates a mount point in /media so I can browse to that from the Meld User Interface but hidden files and folders are not visible and I need to include them in the comparison.

How can I open the iso file in Caja file explorer so that Hidden files and folders are visible so I can then browse to the iso file contents to include it in a Meld Comparison?

Update 1

I think my problem can be summarised like this... "Why does Disk Image Mounter NOT show hidden files/folders by default in an ISO file but it DOES show hidden files/folders in a .img file"?

Because from testing, that's what I'm seeing. My iso file is (hopefully) and exact copy of the img file... yet when I open the iso using "Disk Image Mounter" the hidden files and folders are not visible in Caja.

And yes I found a mount command that does this...

sudo mount -t udf -o loop,unhide [iso file] [mount point]

But I want to understand why the hidden files are not visible in Caja when I use Disk Image mounter from the "Open with" option on the right click menu. Maybe it's because of how I created the ISO file? I used Joliet and ISO something and UDF and lots of other options I didn't really understand... (in the ImgBurn tool).

Update 2

Thanks for everyone's answers. I created a new question because really what I want to understand is why Disk Image mounter does not show hidden files when I use it to open the ISO file.

2
  • 1
    Did you try comparing checksums? You can run sha256sum filename for each file and compare them. If the files are identical, the checksums will match. You are using different file types though, so this may prevent you from doing what you are trying to do.
    – Nmath
    Aug 11, 2021 at 21:28
  • 1
    You can create mountpoints /mnt/pt1 /mnt/pt2 and try to use 'loop mount' like so: sudo mount -o loop file.iso /mnt/pt1 and sudo mount -o loop file.img /mnt/pt2 and see the files at the mountpoints. If the img file has an internal partition structure, you can use kpartx to create device items for each partition and then mount these. See also this link.
    – sudodus
    Aug 11, 2021 at 21:40

1 Answer 1

1

Meld doing such operations ineffectively slow.

I assume that you have correctly mounted both images.

Then I would recommend to install FreeFileSync instead from FlatHub by

sudo apt-get install flatpak
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install flathub org.freefilesync.FreeFileSync

then launch FreeFileSync using dash or flatpak run org.freefilesync.FreeFileSync and run comparison in File Contents mode:

FreeFileSync in File Contents mode


FreeFileSync works great in conjunction with Meld (sudo apt-get install meld) for comparison of file-contents.
You need to open FreeFileSync options (ToolsOptions) and then add the following to the first line:

Description Command line
Compare files in Meld meld "%item_path%" "%item_path2%"

as shown on screenshot:

FreeFileSync Tools→Options

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .