8

When opening gnome software and clicking the update icon, then these errors show up.

Should I ignore it?

error1

error2

EDIT 2021-12-21: None of the answers below seems to work.

1
  • 1
    I am seeing a similar error since quite a while, though it's "The name :1.109 was not provided by any .service files" in my case. I also find this bug with more details in the syslog: systemd[1]: apt-daily-upgrade.service: Succeeded. systemd[1]: Finished Daily apt upgrade and clean activities. gnome-software[4331]: not GsPlugin error FwupdError:10: The name :1.109 was not provided by any .service files gnome-software[4331]: not handling error failed for action refresh: The name :1.109 was not provided by any .service files …and this repeats 2 more times.
    – w-sky
    Commented Sep 17, 2021 at 9:54

4 Answers 4

8

This command solve the issue:

sudo apt install --reinstall gnome-software

I put it as an answer here for improving the visibility of hosford42 comment. All credits to him.

2
  • 1
    Reinstalling gnome-software solves the issue for a short time, but you still have to issue this command again after a while. Commented Apr 29, 2022 at 7:00
  • Only a more explicit sudo apt autoremove gnome-software && sudo apt install gnome-software seems to have worked for me (and now I wonder where I found it but surely wasn't my idea :) )
    – brezniczky
    Commented May 25, 2022 at 22:40
3

Seems to be an issue on several distros (Zorin, RedHat, Arch...). Based on this post:

sudo apt clean 
sudo du -sh /var/cache/apt/ && sudo rm -rf /var/cache/apt/
pkill gnome-software; pkcon refresh force

pkcon comes with PackageKit (packagekit-toolspackage), a distro-agnostic alternative to apt.

1
  • This solve the issue.
    – Joao M
    Commented Jan 17, 2023 at 18:56
1
+50

Try with

sudo apt install policykit-1

It might help.

4
  • Didn't work :( , thanks anyway for answering. But if no one can my answer then you get the bounty for answering my question.
    – MandiYang
    Commented Aug 26, 2021 at 13:58
  • 1
    The error means that the gnome-software app is not connecting to a file that helps populate some if not all the software inside the window dialog. Do you have any apps installed thru Flatpak? If yes do; #$ flatpak list This will show you a list of apps installed thru flatpak In my case; org.audacityteam.Audacity/x86_64/stable so the NAME will be; org.audacityteam.Audacity so! run; #$flatpak update NAME FOR EACH APP if not then try to reinstall gnome-software to allow it to regain access to the right links, if that makes any sense! Commented Aug 27, 2021 at 2:01
  • 4
    sudo apt install --reinstall gnome-software seems to have done the trick.
    – hosford42
    Commented Nov 24, 2021 at 17:23
  • @hosford42 that solved the problem for me --- you should add this as an answer!
    – Rmano
    Commented Dec 1, 2021 at 8:27
0

If the problem its with the flatpak apps maybe you can try to run:

sudo apt install gnome-software-plugin-flatpak
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .