1

Sometime in July, my computer stopped booting into Ubuntu. I found out that i could boot using the "Advanced Options for Ubuntu" but then the first option stopped working and i had to use the second and that went on until at some point i lost the ability to boot into Ubuntu altogether.

Later, i found i could boot using one of the recovery mode options (the second to last one) so i booted and changed the settings so the computer would never hibernate or turn off. I believe that the problem has something to do with my GPU drivers (which were installed during Ubuntu installation and when the problems started, i installed the drivers from the nvidia website).

Sometime in mid-September, I decided to re-install Ubuntu (note Ubuntu is installed on a SATA drive, Windows is installed on an NVME drive and all bootloaders are on the Windows drive). After the installation, I realized nothing had changed except for the fact that I could use any recovery option from the boot menu (there were only two recovery and two normal advanced boot options after reinstalling.

I then installed the nvidia drivers from the "Additional Drivers" application and when I tried to reboot, I found out I could only use the last recovery option. On a side note, I have tried everything user bw3u suggested with no success. Is there any way to fix the problem and is there any chance the GPU has partially failed?

Additional information: When i try to boot, i get the HP logo but no Ubuntu logo, then a black screen and nothing happens. With some "Advanced Options" i get a blinking cursor which freezes and then sometimes the computer boots (I think there are times when the cursor doesn't freeze and that's when the computer boots).

With one specific boot option, i get both the HP and Ubuntu logos, then the screen brightness changes, and after a few seconds i get a black screen and nothing happens. i have Windows 10 as a secondary OS and it boots just fine.

My computer is a HP Pavilion Gaming 15-dk1013nv.

inxi -G output:

Graphics:
  Device-1: Intel UHD Graphics driver: N/A
  Device-2: NVIDIA driver: N/A
  Display: x11 server: X.Org 1.20.11 driver: fbdev
  unloaded: modesetting,vesa resolution: 1920x1080~77Hz
  OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3

I got these while the computer was booted with the last recovery option.

10
  • @Nmath I did not ignore the problem. I tried some solutions i could think of and failed
    – Hristos
    Aug 6 at 20:05
  • How did you install the nVidia driver? You need the one that Ubuntu repository suggests. And if you installed more than one, you create conflicts. You have to purge first as new driver does not fully remove old one. #What is installed dkms status recovery mode boot uses nomodeset boot parameter, which bypasses any proprietary driver.
    – oldfred
    Aug 6 at 20:48
  • @oldfred During installation, there was an option to install third party drivers or something...
    – Hristos
    Aug 6 at 21:04
  • If that is the case, you should edit your question and include more details about the problem(s) that you found and the solution(s) you attempted as well as the detailed results of each attempt. The point is that the problem is now a month old and your actions (or inactions) could have actually made the problem worse. We just don't know and can't advise on this unless we know what you did. Help us help you: include more details that might help illuminate the actual problem.
    – Nmath
    Aug 6 at 22:11
  • @Nmath My attempts were mainly about the graphics drivers and the boot process. (Nothing very interesting or complicated.) I will update the question with more details tomorrow.
    – Hristos
    Aug 6 at 22:48
2

Seems you are a victim of Nvidia Optimus :)

Can you try adding nouveau.modeset=0 to your kernel parameters and boot if it doesn't work try with nomodeset.

  1. If you don't know how to add a kernel parameters when in boot menu press e key when highlighting the kernel.

  2. You should be able to see and edit the commands associated with the highlighted kernel. Find the line starting with linux and add the parameter end of the line (after quiet splash). Press CTRL + x or F10 to boot.

Edit: After booting to your system fire up a terminal and remove Nvidia drivers with;

sudo apt purge nvidia*

Thanks for pointing out @ChanganAuto, you can uninstall binary drivers with running the .run file again;

./NVIDIA-Linux-x86_64-version.run --uninstall

I assume you didn't installed bumblebee or something similar. Launch Software & Updates Select Additional Drivers tab then click to Using NVIDIA driver metapackage from nvidia-driver-470 (proprietary, tested) click Apply changes.

Just in case rebuild kernel modules with;

sudo update-initramfs -u

Reboot your computer you are good to go.

4
  • This conversation has been moved to chat - hope this works for y'all
    – Zanna
    Aug 11 at 14:35
  • @bw3u I suppose you never answered because you have run out of ideas. However, please let me know if that's the case or not.
    – Hristos
    Sep 16 at 11:40
  • @Hristos I am actually not run out of ideas but seems you are a Linux newbie until you have gained some experience I think the best scenario is that you should reinstall fresh Ubuntu to your system. Because this topic is exceeded asking questions it became a technical support which I gave you the instructions. Others are free to answer tho maybe I am wrong :)
    – bw3u
    Sep 18 at 11:05
  • @bw3u I am not really a newbie on Linux generally (even though i am not really advanced either) but i am a newbie on the pre-boot process. I have even re-installed Ubuntu and nothing changed. It looks like a hardware issue but Windows can fully use the GPU which would not be possible if it was fried...
    – Hristos
    Sep 20 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.