I'm trying to install Docker on Ubuntu 20.04

I started with documentation from the developer, got problem on 4th step

sudo apt-get install docker-ce docker-ce-cli containerd.io
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет docker-ce недоступен, но упомянут в списке зависимостей другого
пакета. Это может означать, что пакет отсутствует, устарел или
доступен из источников, не упомянутых в sources.list

E: Для пакета «docker-ce» не найден кандидат на установку
E: Невозможно найти пакет docker-ce-cli
E: Невозможно найти пакет containerd.io
E: Не удалось найти ни один пакет с помощью шаблона «containerd.io»
E: Не удалось найти ни один пакет с помощью регулярного выражения «containerd.io

Then I tried other instruction:

At first upgrade package lists:

sudo apt update

Then install packages to allow APT to function using HTTPS:

sudo apt install apt-transport-https ca-certificates curl software-properties-common

Add GPG key for official Docker repository to your system:

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -

Add Docker repository to APT sources:

sudo add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu focal stable"

Then update package database:

sudo apt update

Make sure that installation will run using Docker repository:

apt-cache policy docker-ce

You should get output like shown below (while Docker version may vary): Output of apt-cache policy docker-ce

 Installed: (none)
 Candidate: 5:19.03.9~3-0~ubuntu-focal
 Version table:
    5:19.03.9~3-0~ubuntu-focal 500
       500 https://download.docker.com/linux/ubuntu focal/stable amd64 Packages

Please note that docker-ce package is not installed, but acts as package installation candidate of Docker for Ubuntu 20.04 (focal version).

Install Docker:

sudo apt install docker-ce

While following the guide above it stopped again with:

Распаковывается docker-ce-cli (5:20.10.8~3-0~ubuntu-bionic) …
dpkg-deb (подпроцесс): разжимающий элемент архива: ошибка lzma: сжатые данные по
dpkg-deb: ошибка: <decompress> subprocess returned error exit status 2
dpkg: ошибка при обработке архива /tmp/apt-dpkg-install-i7eupn/2-docker-ce-cli_5
%3a20.10.8~3-0~ubuntu-bionic_amd64.deb (--unpack):
 не удалось скопировать извлечённые данные «./usr/libexec/docker/cli-plugins/doc
ker-buildx» в «/usr/libexec/docker/cli-plugins/docker-buildx.dpkg-new»: неожидан
ный конец файла или потока
Выбор ранее не выбранного пакета docker-ce.
Подготовка к распаковке …/3-docker-ce_5%3a20.10.8~3-0~ubuntu-bionic_amd64.deb …
Распаковывается docker-ce (5:20.10.8~3-0~ubuntu-bionic) …
Выбор ранее не выбранного пакета docker-ce-rootless-extras.
Подготовка к распаковке …/4-docker-ce-rootless-extras_5%3a20.10.8~3-0~ubuntu-bio
nic_amd64.deb …
Распаковывается docker-ce-rootless-extras (5:20.10.8~3-0~ubuntu-bionic) …
Выбор ранее не выбранного пакета docker-scan-plugin.
Подготовка к распаковке …/5-docker-scan-plugin_0.8.0~ubuntu-bionic_amd64.deb …
Распаковывается docker-scan-plugin (0.8.0~ubuntu-bionic) …
Выбор ранее не выбранного пакета liberror-perl.
Подготовка к распаковке …/6-liberror-perl_0.17029-1_all.deb …
Распаковывается liberror-perl (0.17029-1) …
Выбор ранее не выбранного пакета git-man.
Подготовка к распаковке …/7-git-man_1%3a2.25.1-1ubuntu3.1_all.deb …
Распаковывается git-man (1:2.25.1-1ubuntu3.1) …
Выбор ранее не выбранного пакета git.
Подготовка к распаковке …/8-git_1%3a2.25.1-1ubuntu3.1_amd64.deb …
Распаковывается git (1:2.25.1-1ubuntu3.1) …
Выбор ранее не выбранного пакета slirp4netns.
Подготовка к распаковке …/9-slirp4netns_0.4.3-1_amd64.deb …
Распаковывается slirp4netns (0.4.3-1) …
При обработке следующих пакетов произошли ошибки:
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • 1
    Please ask and provide output in English - I suspect the amount of people who can help you in Russian is severely limited. Aug 9, 2021 at 9:16
  • What is your Ubuntu version? Why do you mix focal (20.04 LTS) and bionic (18.04 LTS)?
    – N0rbert
    Aug 9, 2021 at 9:28
  • Please include the output of grep -ir "^deb" /etc/apt/ --include=*.list, apt-cache policy docker-ce-cli docker-ce to the question. Which storage do you use? Are you sure it operates well? Your output has "<decompress> subprocess returned error" which may mean potential filesystem corruption. Have you tried to run sudo apt-get clean and retry?
    – N0rbert
    Aug 9, 2021 at 11:34
  • I don't understand where bionic (18.04 LTS) comes from. Where do you see this? How can I fix this?
    – alex
    Aug 9, 2021 at 11:37
  • "Распаковывается docker-ce-rootless-extras (5:20.10.8~3-0~ubuntu-bionic) …" . And please answer the questions.
    – N0rbert
    Aug 9, 2021 at 11:42


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.