1

I have installed Java 11 from this site - https://bell-sw.com/pages/repositories/#apt by using the following commands:

wget -q -O - https://download.bell-sw.com/pki/GPG-KEY-bellsoft | sudo apt-key add -
echo "deb [arch=amd64] https://apt.bell-sw.com/ stable main" | sudo tee /etc/apt/sources.list.d/bellsoft.list
sudo apt-get update
sudo apt-get install bellsoft-java11

Currently I get:

"Следующие пакеты имеют неудовлетворённые зависимости: default-jre-headless : Зависит: openjdk-11-jre-headless но он не будет установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение)."

Tried to use apt --fix-broken install

"Подготовка к распаковке …/openjdk-11-jre-headless_11.0.11+9-0ubuntu2~20.04_amd64 .deb … Распаковывается openjdk-11-jre-headless:amd64 (11.0.11+9-0ubuntu2~20.04) … dpkg-deb (подпроцесс): разжимающий элемент архива: ошибка lzma: сжатые данные повреждены dpkg-deb: ошибка: subprocess returned error exit status 2 dpkg: ошибка при обработке архива /var/cache/apt/archives/openjdk-11-jre-headles s_11.0.11+9-0ubuntu2~20.04_amd64.deb (--unpack):

не удалось скопировать извлечённые данные «./usr/lib/jvm/java-11-openjdk-amd64/ lib/modules» в «/usr/lib/jvm/java-11-openjdk-amd64/lib/modules.dpkg-new»: неожиданный конец файла или потока

При обработке следующих пакетов произошли ошибки: /var/cache/apt/archives/openjdk-11-jre-headless_11.0.11+9-0ubuntu2~20.04_amd64. deb E: Sub-process /usr/bin/dpkg returned an error code (1)"

3
  • What was wrong with default-jre which is packaged for Ubuntu at the same 11 version? Why do you install Java from third-party vendor? Please include the output of grep -ir "^deb" /etc/apt/ --include=*.list, apt-cache policy default-jre-headless openjdk-11-jre-headless and update-java-alternatives -l to the question.
    – N0rbert
    Aug 9, 2021 at 7:12
  • I don't need a JRE, but a JDK. Namely, this version of the JDK is recommended for working with Kubernetes. I switched from Windows to Linux, I hoped that there would be less problems with Docker
    – alex
    Aug 9, 2021 at 8:26
  • You may want to convert the messages to English not much help here otherwise.
    – David
    Aug 11, 2021 at 5:45

1 Answer 1

1

You have broken download. To fix it open terminal and run the following commands:

sudo apt-get clean

sudo apt-get install -f
sudo dpkg --configure -a

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .