6

Until two days ago, using two monitors in Ubuntu 20.04 was no problem. However, since yesterday, this is not possible anymore, even though I did not change the cable setup or anything. Also, when I go to "Settings"-->"Displays", it shows me "Unknown Display" whereas previously it had showed me the two connected monitors. I have an Nvidia GPU built in, any help would be appreciated.

Edit 1: Interesting, this problem does not occur under Windows where I can use my two monitors without any problems. My setup is a tower PC, an Nvidia GeForce GT 610 is built in.

Edit 2: The problem is solved now, cf. the accepted answer.

2
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Mitch
    Commented Aug 13, 2021 at 10:45
  • who is cf? what accepted answer? There isn't one yet...
    – Nate T
    Commented Aug 14, 2021 at 13:16

2 Answers 2

4
+100

Two monitors with Ubuntu 20.04 LTS - now with the Linux driver nouveau

I have a somewhat similar system [as the original poster]. I updated and upgraded my Ubuntu 20.04 LTS in a Dell m4800 with nvidia graphics.

After reboot it can still feed two screens, one internal monitor and a 40 inch TV. I have them 'side by side' and can move windows from the internal monitor to the TV with the touchpad.

But I noticed that the system had automatically turned off the proprietary driver and was using nouveau (the free Linux driver). The performance playing video is good, I did not notice any significant difference in quality.

It works also for the original poster to switch to the free Linux driver, nouveau, and it can be a good alternative also for other users who are affected by this problem. (Let us hope that there will soon be a working solution with a proprietary nvidia driver too.)

To switch the drive, go to "Software & Updates", then under "Additional Drivers" and finally choose the Nouveau driver.

1

This kind of problems is typically related to driver issues. Check if, in grub, booting to an earlier kernel solves the problem.

Also, identify when was the last boot

$ journalctl --list-boots

and update (output may well be in excess of what is needed, but it doesn't hurt)

$ zgrep "linux" /var/log/dpkg.log* | grep " install "
$ zgrep "nvidia" /var/log/dpkg.log* | grep " install "

In addition to posting this output, please post the output of

$ inxi -v 2
$ xrandr
$ ubuntu-drivers devices

If you don't have inxi and/or ubuntu-drivers you can install them with sudo apt install inxi ubuntu-drivers.

If you don't have the latest nvidia drivers, I suggest you install them with, e.g.,

$ sudo apt install nvidia-driver-470

and reboot.

5
  • To be honest, I am not sure I know how exactly I would "Check if, in grub, booting to an earlier kernel solves the problem." I will edit my post with the information you asked.
    – Hermi
    Commented Aug 11, 2021 at 20:07
  • @Hermi - askubuntu.com/questions/82140/… Commented Aug 11, 2021 at 23:34
  • @Hermi - Please see EDITed answer, and post feedback on all items asked about. Commented Aug 12, 2021 at 14:41
  • Thank you for the effort, but the problem already got solved. Thanks!
    – Hermi
    Commented Aug 12, 2021 at 19:30
  • @Hermi - That is great! If you could try also applying the proprietary driver, that would be a plus. In addition, the performance is generally reported to range from similar to much better, depending on your uses. Commented Aug 12, 2021 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .