4

Some native games work fine, but some don't. Mostly it happens with wine games. I play a lot of adventure games and I try to play ags games a good amount because there are a lot of them and they work great under wine.

When I play games the unity icon bar and universal toolbar show through. Sometimes on native games but always on wine games. Is there anyone else this happens to and is there a way to fix this?

[edit] For some reason the site won't let me comment??? Yes sorry, it's when I try to fullscreen the game.

  • So, from what I understand, you want it to be so that the game is complete full screen with absolutely no Unity bar and top panel toolbar? Just for clarification – Ryan McClure May 11 '12 at 20:15
6

If you are having the same issue I have, and it sounds like you do, try unchecking Allow the window manager to control the windows in the Graphics section of winecfg. Works for me, no Dash or titlebar in fullscreen.

| improve this answer | |
2

I have this problem with some games using WINE(actually Crossovers version) from what I have been able to gather WINE and Compiz can have some issues playing well together. Some games work fine others will show the top bar and launcher. If I remember right this usually results from poor programming in the Windows program you are trying to run(I could be wrong on that, I am going entirely from memory here)

I have no problem with these same games if I log into Unity 2D which doesn't use Compiz. I wish I could give you the links I found about this but I don't remember where they were.

As far as the native Linux games, I don't have any games that I noticed having this problem, if I use the fullscreen option the native ones I have all cover the whole screen.

| improve this answer | |
1

The solution of pgschk works great, but has one major problem: You cannot move the mouse outside and work outside of wine. For example, if a wine application is opened which doesn't allow to control the window, if you click in firefox search, you cannot type with your keyboard.

But there is also another solution, which is more general, as it works not only for wine, but also for other applications (as for example some java apps) which need fullscreen: Enable 'legacy fullscreen' in compizconfig-settings-manager.

Steps:

  1. Install the compizconfig-settings-manager, if not already installed

    $sudo apt-get update && sudo apt-get install compizconfig-settings-manager
    
  2. Open the compizconfig-settings-manager (can also be found in the unity lens by searching for 'compiz')

    $ccsm
    
  3. Click on the tab 'Advanced Search', which can be found below 'Categories' and 'Settings'

  4. A list of Plugins will be shown. Select 'Workarounds'

  5. Enable 'Legacy Fullscreen Support' (currently the second item in the list)

  6. Restart your application in fullscreen and enjoy a screen without the unity bars :-)

| improve this answer | |
0

Then I guess you have two options: switch between window/fullscreen modes in your games and if possible set your native desktop resolution, this should hide all unity/gnome panels. The other option would be to check 'emulate desktop' option in winecfg and set it to you native desktop resolution.

| improve this answer | |
-1

I had the same problem running full screen games on Wine. I solved this by installing the openbox.

  • Open terminal.
  • type: sudo apt-get install -y openbox and press Enter
  • Wait for the installation to finish.
  • Restart the system and in the login screen select openbox as desktop

However it is necessary to start games from terminal.

| improve this answer | |
  • Ask Ubuntu operates in English only, so I have removed your answer that you had in another language. Thank you, and welcome to Ask Ubuntu! – zwork Aug 8 '17 at 11:55
  • Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Aug 8 '17 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.